Jump to content

Impossible to read temperature withGPIO

Recommended Posts

Hello everyone.

I need to measure temperature with a DHT11 using Python and I can't get it. I have a tinker board R2.0 and the latest version of Tinker OS. I have tried with two Adafruit libraries: Adafruit_DHT and adafruit-circuitpython-dht.

With the first package, which I think is the simplest and has worked on my raspberry, I get the following error:

raise RuntimeError('Error accessing GPIO. Make sure program is run as root with sudo!')
RuntimeError: Error accessing GPIO. Make sure program is run as root with sudo!

I have tried to run the program from the terminal as root with sudo but the same problem still appears.

I have tried to measure with a DS18B20, but the libraries I find are not compatible with the tinker board either.

I also tried with a MCP9600, which works with I2C, but it doesn't work either. When I search for the address with i2cdetect -y 1 it only recognizes the MCP the first time. If I use i2cdetect -y 1 again, it does not appear anymore. I have to disconnect and reconnect the device for i2cdetect -y 1 to detect it.

I don't care which of the three methods to use to measure temperature. I would like to know if anyone has managed to use any of these three methods. I have tried with a Raspberry Pi 3B the same libraries and had no problems. I'm a bit desperate with the tinker board 😖

Thanks a lot



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...