Jump to content


Popular Content

Showing content with the highest reputation since 06/05/2022 in all areas

  1. 3 points
    could you guys release 1 for kernel 5.15.x please? or share how we can compile our own kernels?
  2. 1 point
    hello @saeed soleimanifar, you can get the console log disabled by modifying the /boot/cmdline.txt: console= save and then reboot
  3. 1 point
    hello @Suntech, the easiest way would be using the dd command to clone everything out of the board then use flashtools such as balena etcher to flash the .img to other boards. 1. connect tinker board 2s to an ubuntu machine 2. to check if tinker board 2s has been recognised, use lsblk 3. to clone the eMMC: sudo dd if=/dev/sdb of=(filename).img bs=1G this will take a while, i've waited for around 35 minutes or so 4. once the cloning is finished, copy the .img file and use flashtools such as balenaetcher to flash the os to other boards *if you don't have an ubuntu machine, you can plug a flash drive to tinker board 2s, and save the output file to the flashdrive (please ensure it's got enough space) change #3 to: sudo dd if=/dev/sdb of=of=/dev/<USB device_name> bs=1G **if you're using a windows pc, you can use win32 disk imager: Win32 Disk Imager - Download [Official Site] 1. connect tinker board 2s to the pc 2. whilst tinker board 2s is in ums mode, use win32 disk imager to copy the emmc Using dd to clone eMMC OS.pdf
  4. 1 point
  5. 1 point
    Hi guys. Let me share Android 11 for Tinkerboard / Tinkerboard S 1-st revision (not R2.0) which Asus marked as outdated/legacy. You can find download link below: Download Android 11 ROM Tinkerboard (not R2.0) Bug reporting are welcome. Release is based on official Asus firmware for Tinkerboard S R2.0.
  6. 1 point
    hello @sonyan11, i think you're able to modify uvcvideo driver to module mode through menuconfig, but tinker board 2s is not able to recognize the new module because the module driver is not updated to tinker board 2s. to update tinker board 2s' module driver, please execute these two commands in the kernel directory of the source code, make ARCH=arm64 modules make ARCH=arm64 modules_install INSTALL_MOD_PATH={INSTALL_PATH} and then update the \lib\modules\4.4.194\ kernel and \lib\modules\4.4.194\modules (of which from {INSTALL_PATH} ) onto tinker board 2s accordingly
  7. 1 point
    hello @sathish, it is not built in the tinker os, if you'd like to use dhcpcd: sudo apt-get install dhcpcd5 the dhcpcd.con will be locaed in /etc/ alternatively, you can use nmcli con mod to configure the ip network
  8. 1 point
    hello @sathish, perhaps you can use gst-play-1.0, command: gst-play-1.0 FILE|DIRECTORY|URI [FILE2|DIRECTORY2|URI2] https://gstreamer.freedesktop.org/documentation/frequently-asked-questions/using.html?gi-language=c#how-do-i-use-the-gstreamer-command-line-interface
  9. 1 point
    hello @sushil, is this the library you're using? mattjlewis/diozero: Java Device I/O library that is portable across Single Board Computers and microcontrollers. Tested with Raspberry Pi, Odroid C2, BeagleBone Black, Next Thing CHIP, Asus Tinker Board and Arduinos / Pico. Supports GPIO, I2C, SPI as well as Serial communication. Also known to work with Udoo Quad. (github.com)
  10. 1 point
    hello @lbispo, we've verified with tinker edge t mendel os when using two cameras, both cameras can be recognised. please give it a try.
  11. 1 point
    Hi @tooz I'm facing an issue using the webcam inside our electron.js app. we are trying to build electrojs app and use the camera feed inside of it, but it's rendered as a black screen, and we get these errors in the console. libGL error: unable to load driver: rockchip_dri.so libGL error: driver pointer missing libGL error: failed to load driver: rockchip libGL error: unable to load driver: rockchip_dri.so libGL error: driver pointer missing libGL error: failed to load driver: rockchip do you have any idea about those errors?
  12. 1 point
    to compile boot.img: source build/envsetup.shlunch WW_Tinker_Board_2-userdebug./build.sh -CKA it'll be located in directory: rockdev/Image-WW_Tinker_Board_2/
  13. 1 point
    hello @kaestli, i use asus adp-33aw x, it's a pretty general one, similar to this: https://www.amazon.com/Adapter-Charger-Compatible-Vivobook-X200MA/dp/B07WC4F1J4/ref=sr_1_10?crid=1X289V37LE3ZA&keywords=adp+33aw&qid=1675320094&sprefix=adp+33a%2Caps%2C279&sr=8-10
  14. 1 point
    hello @marco@bigsis.tech, there are different ways and tools to copy/ dump the os either from emmc or sdcard. the easiest way i can think of is to use dd command, usually i clone the os to sdcard and use balena etcher to flash other boards; if your two tinker edge r's are conencted to the same pc, you can direct the path to the board that you're going to flash. 1. insert a sdcard, using lsblk to check its path, in my case it's /dev/mmcblk0 2. clone the os sudo dd if=/dev/mmcblk0 of=/dev/sda/emmc.img conv=noerror,sync or sudo dd if=/dev/mmcblk1 of=/dev/mmcblk0 bs=4M here i clone the whole system and it takes around 18 minutes 3. once it's done, you can use the sdcard to flash another tinker edge r under ums mode, using tools such as balena etcher
  15. 1 point
    hello @marco@bigsis.tech, 1. connect tinker edge r to the computer 2. shutdown tinker edge r 3. repower tinker edge r so it can be switched to ums mode 4. use tools such as balena etcher to flash
  16. 1 point
    hello @paul_nicholls, this is a tinker board '1.2' with no emmc (rk3288 based), you can download one of the images and burn it into microsd with balenaetcher android 12: Tinker Board R2.0 /Tinker Board S R2.0 Android 12 V0.0.3 debian 10: Tinker Board S R2.0 Debian 10 V3.0.11
  17. 1 point
    hello @CardeLL, try 're-writing the os using ums from a micro sd card': User-Manual.pdf (asus.com)
  18. 1 point
    /dtoverlay/config.txt does not exist in Android 11 v1.0.0 Tinkerboard S R2.0 release. There are only cmdline.txt file and overlays folder: WW_Tinker_Board:/dtoverlay $ ls -la total 24 drwxrwxrwx 3 root root 16384 2021-12-14 01:16 . drwxr-xr-x 25 root root 4096 2021-12-14 00:43 .. -rwxrwxrwx 1 root root 58 2021-12-14 00:46 cmdline.txt drwxrwxrwx 2 root root 2048 2021-12-14 00:46 overlays WW_Tinker_Board:/dtoverlay $
  19. 1 point
    nevermind. i solved this portion. posted the guide here for anyone who is interested: https://github.com/wahahawasabi/TinkerBoard2s
  20. 1 point
    hello @kokim_gt, you will have to port and configure tw9992 driver for mipi-csi. awb_v10.c is the library that rockchip uses for awb processing and we do not have source code, something related to rockchip image processing was changed (in this case, ov5647 driver) hence why the rkisp_3a errors. both tw9992 and adb7282m convert analog video(ntsc/pal) to yuv image through mipi-csi output, such application hasn't been implemented in tinker series, as far as i know
  21. 1 point
    Hi everyone, I am searching for a simple "standalone" video looper software for the Tinkerboard (R2.0), similar to the Adafruit videolooper for the RaspbePi. Can anyone help me please? I am searching for sth that runs on reeboot (e.g. after crash or no electricity) so that the looper starts immeadiatley after booting, no keyboard or mous manipulation needed. Even better woudl be if it would be possible to add keyboartd shortcuts like fast forward (usually key L on keyboard) and fast backward (J) and K is usually stop/pause and play. Thank you very much in advance if you have an idea. At the moment I'm downbloading Kodi, but this always needs to be manipulated to start video... 😞 Cheers and a solution will be much appreciated 🙂 Polly
  22. 1 point
    Kernel Build Questions in Tinker Edge T I installed Mendel 5 Eagle V3.0.2 on Tinker Edge T. I want to change Boot Logo of Tinker Edge T, and I want to communicate with UART device in Mendel Linux. To change the Boot Logo, Kernel must be compiled. Where can I download the kernel source for Mendel 5 Eagle V3.0.2? And, what do I need to do to communicate with the UART device in mendel linux? Guid documentation says /dev/ttymxc0 and /dev/ttymxc2 should exist, but I see /dev/ttymxc0 and /dev/ttymxc1. If /dev/ttymxc1 is checked, it is said to be incorrect. I need help with the above two. regards.
  23. 1 point
    Hi Nott: Can you try ?? wget https://github.com/electron/electron/releases/download/v11.2.3/chromedriver-v11.2.3-linux-arm64.zip unzip chromedriver-v11.2.3-linux-arm64.zip ./chromedriver Thanks.
  24. 1 point
    hello @sonyan11, uvcvideo is compiled into the kernel, tasks that are module-related cannot be supported as uvcvideo by default is not part of the module. it's necessary to change uvcvideo to module and rebuild the image in order to make the modules work.
  25. 1 point
    hello @metala, the two parts used here are: MURATA/DLW21SN900HQ2L , CHILISIN/CMHD21T-900M-N
  26. 1 point
  27. 1 point
    hello @Chridster1, thanks for the update, i'll discuss with team in terms of meta-layer releases; for the build issue, please try prebuilt gcc and see if it works: $ make ARCH=arm64 CROSS_COMPILE=../prebuilts/gcc/linux-x86/aarch64/gcc-linaro-6.3.1-2017.05-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- tinker_board_2_defconfig $ make ARCH=arm64 CROSS_COMPILE=../prebuilts/gcc/linux-x86/aarch64/gcc-linaro-6.3.1-2017.05-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- rk3399-tinker_board_2.img -j8
  28. 1 point
    hello @Junhyuk Oh, please revert these two changes from kernel: a11f35719c4d logo: change linux kernel logo by ADC request. 95e5b2643333 logo: Show linux logo and dump kernel log to display during system booting.
  29. 1 point
    hello @hasank, we cannot reproduce the issue, but for most cases external disks without individual power supply consume a lot of power that causes connection problem. we'd suggest to use a seperate power supply for the external disk, otherwise use an usb hub with external power supply.
  30. 1 point
    Unfortunately Asus made Tinker Board, sold it and forgot. What makes Raspberry pi popular is the software support behind it. In this forum, your posts are approved very late and receive no response. Unfortunately, I also bought Tinker Board 2S. I regret. There is no support.
  31. 1 point
    I couldn't find a complete solution to the problem but here is one way to install: sudo apt update sudo apt -y upgrade sudo apt install apache2 sudo apt install mariadb-server sudo mysql_secure_installation sudo apt install -y lsb-release ca-certificates apt-transport-https software-properties-common gnupg2 wget -qO - https://packages.sury.org/php/apt.gpg | sudo apt-key add - sudo apt update sudo apt install php8.1 ------------------------------------------ when clogged press ctrl+z ------------------------------------------ sudo reboot sudo dpkg --configure -a sudo apt install php8.1-{bcmath,fpm,xml,mysql,zip,intl,ldap,gd,cli,bz2,curl,mbstring,pgsql,opcache,soap,cgi} sudo apt -y upgrade Apache + Mysql + Php 8.1
  32. 1 point
    $ sudo dd if=/dev/mmcblk1 of=/home/linaro/Desktop/mmcblk1.img bs=X count=Y conv=noerror,sync [NOTE]: X means Block size; Y means Processing number of blocks. X*Y has to a little bit bigger than the resized capacity. The dd procedure needs to reserve some space to process. If the reserve space is not enough, the dd procedure would be failed. For example: For this case, the bs would be 5M and count would be 1000 and the created image size would be 5GB totally. Then the created image could be restored back to the whole storage of the next board by dd/ecther/Win32DiskImager. PS: u can follow way to rezise storage partition before u backup the image https://github.com/TinkerBoard/TinkerBoard/wiki/Developer-Guide#for-tinker-board-2s
  33. 1 point
    I try to use balena Etcher to install https://github.com/home-assistant/operating-system/releases/download/7.4/haos_tinker-7.4.img.xz in UMS mode. But it failed to boot up. No any screen information or current status show off. Did anyone success to install home assistant?
  34. 1 point
    Samba doesn't want to be installed using other dependencies as an excuse. but i solved his problem. it's ok with one command, like this: sudo apt-get install python-samba samba-common-bin samba-libs samba libwbclient0 libsmbclient
  35. 1 point
    I've made some progress: I purge ufw and iptables, then install iptables first then change to iptables-legacy. after that install ufw. ufw seems to works only on iptables-legacy. apt purge ufw iptables apt install iptables update-alternatives --set iptables /usr/sbin/iptables-legacy update-alternatives --set ip6tables /usr/sbin/ip6tables-legacy apt install ufw now: root@linaro-alip:~# ufw allow ssh ERROR: initcaps [Errno 2] modprobe: FATAL: Module ip6_tables not found in directory /lib/modules/4.4.194 ip6tables v1.8.2 (legacy): can't initialize ip6tables table `filter': Table does not exist (do you need to insmod?) Perhaps ip6tables or your kernel needs to be upgraded. Maybe ip6tables are missing in kernel? root@linaro-alip:~# sudo modprobe ip6_tables modprobe: FATAL: Module ip6_tables not found in directory /lib/modules/4.4.194 root@linaro-alip:~# ^C root@linaro-alip:~# sudo modprobe ip6tables modprobe: FATAL: Module ip6tables not found in directory /lib/modules/4.4.194
  36. 1 point
    Introduction RKNN-Toolkit is a software development kit for users to perform model conversion, inference and performance evaluation on PC, RK3399Pro. AI Compute Stick or RK3399Pro Linux development board. https://github.com/rockchip-linux/rknn-toolkit/tree/v1.3.2
  • Create New...