Jump to content

peterkwon

Members
  • Content Count

    8
  • Joined

  • Last visited

  • Days Won

    1

peterkwon last won the day on October 12

peterkwon had the most liked content!

Community Reputation

1 Neutral

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. self-response The contents of build/Dockerfile were modified. --> FROM debian:10.0 MAINTAINER coral-support@google.com # Install the prerequisite packages into the image. ADD ./build /build ADD ./board /board RUN /bin/bash -c '\ apt-get update && \ apt-get install -y sudo make && \ + apt-get install -y sudo git && \ + apt-get install -y sudo build-essential && \ + apt-get install -y sudo qemu-user-static && \ + apt-get install -y sudo bc && \ ln -sfr /build/Makefile /Makefile && \ source /build/setup.sh && \ make -C /build prereqs' In this way, build-essential, qemu-user-static, and bc are added and build.sh is executed, and the build is in progress.
  2. https://github.com/TinkerEdgeT/mendel-manifest $ repo init -u https://github.com/TinkerEdgeT/mendel-manifest.git -b mendel-eagle-imx_8m $ repo sync After downloading the development environment, run build/setup.sh Run build.sh Check the following error message -------------------------------------------------------------------------- build Message---------------------------------------------------------------------- ./build.sh VERSION_NUMBER: ======================================== ROOTDIR=/home/peterkwon/prj/tinkerBoard_T OUT=/home/peterkwon/prj/tinkerBoard_T/out PRODUCT_OUT=/home/peterkwon/prj/tinkerBoard_T/out/target/product/imx8m_phanbell HOST_OUT=/home/peterkwon/prj/tinkerBoard_T/out/host/linux-x86 ROOT_OUT=/home/peterkwon/prj/tinkerBoard_T/out/root ======================================== Type m to build. /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dts:32.5-18: Warning (reg_format): /fragment@2/__overlay__/pcm5122@4d:reg: property has invalid length (4 bytes) (#address-cells == 2, #size-cells == 1) /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (pci_device_reg): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (pci_device_bus_num): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (simple_bus_reg): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (i2c_bus_reg): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (spi_bus_reg): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dts:29.24-34.6: Warning (avoid_default_addr_size): /fragment@2/__overlay__/pcm5122@4d: Relying on default #address-cells value /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dts:29.24-34.6: Warning (avoid_default_addr_size): /fragment@2/__overlay__/pcm5122@4d: Relying on default #size-cells value /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (avoid_unnecessary_addr_size): Failed prerequisite 'avoid_default_addr_size' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (unique_unit_address): Failed prerequisite 'avoid_default_addr_size' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/waveshare_5inch_dsi.dts:10.12-12.6: Warning (unit_address_vs_reg): /fragment@0/__overlay__/panel@0: node has a unit name, but no reg property *** GUI build selected -- set HEADLESS_BUILD=true if this is not what you intend. *** Building packages locally, set FETCH_PACKAGES=true to use prebuilts mkdir -p /home/peterkwon/prj/tinkerBoard_T/cache/docker-build cp -a /home/peterkwon/prj/tinkerBoard_T/build /home/peterkwon/prj/tinkerBoard_T/cache/docker-build cp -a /home/peterkwon/prj/tinkerBoard_T/board /home/peterkwon/prj/tinkerBoard_T/cache/docker-build cp -a /home/peterkwon/prj/tinkerBoard_T/build/Dockerfile /home/peterkwon/prj/tinkerBoard_T/cache/docker-build docker build -t aiy-board-builder /home/peterkwon/prj/tinkerBoard_T/cache/docker-build [+] Building 7.6s (8/8) FINISHED => [internal] load build definition from Dockerfile 0.0s => => transferring dockerfile: 924B 0.0s => [internal] load .dockerignore 0.0s => => transferring context: 2B 0.0s => [internal] load metadata for docker.io/library/debian:10.0 1.0s => [1/4] FROM docker.io/library/debian:10.0@sha256:2f04d3d33b6027bb74ecc81397abe780649ec89f1a2af18d7022737d0482cefe 0.0s => [internal] load build context 0.0s => => transferring context: 3.56kB 0.0s => CACHED [2/4] ADD ./build /build 0.0s => CACHED [3/4] ADD ./board /board 0.0s => ERROR [4/4] RUN /bin/bash -c 'apt-get update && apt-get install -y sudo make && ln -sfr /build/Makefile /Makefile && source /build/setup.sh && make -C /build prereqs' 6.6s ------ > [4/4] RUN /bin/bash -c 'apt-get update && apt-get install -y sudo make && ln -sfr /build/Makefile /Makefile && source /build/setup.sh && make -C /build prereqs': #0 0.558 Get:1 http://security.debian.org/debian-security buster/updates InRelease [34.8 kB] #0 0.694 Get:2 http://deb.debian.org/debian buster InRelease [122 kB] #0 0.882 Get:3 http://deb.debian.org/debian buster-updates InRelease [56.6 kB] #0 0.900 Get:4 http://security.debian.org/debian-security buster/updates/main amd64 Packages [357 kB] #0 1.286 Get:5 http://deb.debian.org/debian buster/main amd64 Packages [7909 kB] #0 2.154 Get:6 http://deb.debian.org/debian buster-updates/main amd64 Packages [8788 B] #0 3.351 Fetched 8488 kB in 3s (3000 kB/s) #0 3.351 Reading package lists... #0 4.013 Reading package lists... #0 4.659 Building dependency tree... #0 4.769 Reading state information... #0 4.873 The following additional packages will be installed: #0 4.873 lsb-base #0 4.873 Suggested packages: #0 4.873 make-doc #0 4.933 The following NEW packages will be installed: #0 4.933 lsb-base make sudo #0 5.159 0 upgraded, 3 newly installed, 0 to remove and 36 not upgraded. #0 5.159 Need to get 1614 kB of archives. #0 5.159 After this operation, 5259 kB of additional disk space will be used. #0 5.159 Get:1 http://deb.debian.org/debian buster/main amd64 lsb-base all 10.2019051400 [28.4 kB] #0 5.235 Get:2 http://deb.debian.org/debian buster/main amd64 make amd64 4.2.1-1.2 [341 kB] #0 5.400 Get:3 http://deb.debian.org/debian buster/main amd64 sudo amd64 1.8.27-1+deb10u3 [1244 kB] #0 5.789 debconf: delaying package configuration, since apt-utils is not installed #0 5.823 Fetched 1614 kB in 1s (2443 kB/s) #0 5.851 Selecting previously unselected package lsb-base. (Reading database ... 6674 files and directories currently installed.) #0 5.863 Preparing to unpack .../lsb-base_10.2019051400_all.deb ... #0 5.868 Unpacking lsb-base (10.2019051400) ... #0 5.924 Selecting previously unselected package make. #0 5.925 Preparing to unpack .../make_4.2.1-1.2_amd64.deb ... #0 5.929 Unpacking make (4.2.1-1.2) ... #0 6.049 Selecting previously unselected package sudo. #0 6.050 Preparing to unpack .../sudo_1.8.27-1+deb10u3_amd64.deb ... #0 6.058 Unpacking sudo (1.8.27-1+deb10u3) ... #0 6.238 Setting up lsb-base (10.2019051400) ... #0 6.252 Setting up make (4.2.1-1.2) ... #0 6.267 Setting up sudo (1.8.27-1+deb10u3) ... #0 6.337 invoke-rc.d: could not determine current runlevel #0 6.346 invoke-rc.d: policy-rc.d denied execution of start. #0 6.417 /build/setup.sh: line 57: git: command not found #0 6.423 ======================================== #0 6.423 ROOTDIR=/ #0 6.423 OUT=//out #0 6.423 PRODUCT_OUT=//out/target/product/imx8m_phanbell #0 6.423 HOST_OUT=//out/host/linux-x86 #0 6.423 ROOT_OUT=//out/root #0 6.423 ======================================== #0 6.423 #0 6.423 Type m to build. #0 6.427 make: Entering directory '/build' #0 6.441 make: Leaving directory '/build' #0 6.441 Makefile:26: *** qemu-user-static is either not installed or not configured properly.. Stop. ------ Dockerfile:21 -------------------- 20 | ADD ./board /board 21 | >>> RUN /bin/bash -c '\ 22 | >>> apt-get update && \ 23 | >>> apt-get install -y sudo make && \ 24 | >>> ln -sfr /build/Makefile /Makefile && \ 25 | >>> source /build/setup.sh && \ 26 | >>> make -C /build prereqs' 27 | -------------------- error: failed to solve: process "/bin/sh -c /bin/bash -c 'apt-get update && apt-get install -y sudo make && ln -sfr /build/Makefile /Makefile && source /build/setup.sh && make -C /build prereqs'" did not complete successfully: exit code: 2 make: *** [/home/peterkwon/prj/tinkerBoard_T/build/docker.mk:32: /home/peterkwon/prj/tinkerBoard_T/cache/aiy-board-builder.tar] Error 1 /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dts:32.5-18: Warning (reg_format): /fragment@2/__overlay__/pcm5122@4d:reg: property has invalid length (4 bytes) (#address-cells == 2, #size-cells == 1) /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (pci_device_reg): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (pci_device_bus_num): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (simple_bus_reg): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (i2c_bus_reg): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (spi_bus_reg): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dts:29.24-34.6: Warning (avoid_default_addr_size): /fragment@2/__overlay__/pcm5122@4d: Relying on default #address-cells value /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dts:29.24-34.6: Warning (avoid_default_addr_size): /fragment@2/__overlay__/pcm5122@4d: Relying on default #size-cells value /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (avoid_unnecessary_addr_size): Failed prerequisite 'avoid_default_addr_size' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (unique_unit_address): Failed prerequisite 'avoid_default_addr_size' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/waveshare_5inch_dsi.dts:10.12-12.6: Warning (unit_address_vs_reg): /fragment@0/__overlay__/panel@0: node has a unit name, but no reg property *** GUI build selected -- set HEADLESS_BUILD=true if this is not what you intend. *** Building packages locally, set FETCH_PACKAGES=true to use prebuilts mkdir -p /home/peterkwon/prj/tinkerBoard_T/cache/docker-build cp -a /home/peterkwon/prj/tinkerBoard_T/build /home/peterkwon/prj/tinkerBoard_T/cache/docker-build cp -a /home/peterkwon/prj/tinkerBoard_T/board /home/peterkwon/prj/tinkerBoard_T/cache/docker-build cp -a /home/peterkwon/prj/tinkerBoard_T/build/Dockerfile /home/peterkwon/prj/tinkerBoard_T/cache/docker-build docker build -t aiy-board-builder /home/peterkwon/prj/tinkerBoard_T/cache/docker-build [+] Building 8.5s (8/8) FINISHED => [internal] load .dockerignore 0.0s => => transferring context: 2B 0.0s => [internal] load build definition from Dockerfile 0.0s => => transferring dockerfile: 924B 0.0s => [internal] load metadata for docker.io/library/debian:10.0 1.9s => [internal] load build context 0.0s => => transferring context: 3.56kB 0.0s => [1/4] FROM docker.io/library/debian:10.0@sha256:2f04d3d33b6027bb74ecc81397abe780649ec89f1a2af18d7022737d0482cefe 0.0s => CACHED [2/4] ADD ./build /build 0.0s => CACHED [3/4] ADD ./board /board 0.0s => ERROR [4/4] RUN /bin/bash -c 'apt-get update && apt-get install -y sudo make && ln -sfr /build/Makefile /Makefile && source /build/setup.sh && make -C /build prereqs' 6.5s ------ > [4/4] RUN /bin/bash -c 'apt-get update && apt-get install -y sudo make && ln -sfr /build/Makefile /Makefile && source /build/setup.sh && make -C /build prereqs': #0 0.520 Get:1 http://security.debian.org/debian-security buster/updates InRelease [34.8 kB] #0 0.635 Get:2 http://deb.debian.org/debian buster InRelease [122 kB] #0 0.824 Get:3 http://deb.debian.org/debian buster-updates InRelease [56.6 kB] #0 0.857 Get:4 http://security.debian.org/debian-security buster/updates/main amd64 Packages [357 kB] #0 1.239 Get:5 http://deb.debian.org/debian buster/main amd64 Packages [7909 kB] #0 2.078 Get:6 http://deb.debian.org/debian buster-updates/main amd64 Packages [8788 B] #0 3.277 Fetched 8488 kB in 3s (3041 kB/s) #0 3.277 Reading package lists... #0 3.953 Reading package lists... #0 4.582 Building dependency tree... #0 4.691 Reading state information... #0 4.796 The following additional packages will be installed: #0 4.796 lsb-base #0 4.796 Suggested packages: #0 4.796 make-doc #0 4.854 The following NEW packages will be installed: #0 4.854 lsb-base make sudo #0 5.079 0 upgraded, 3 newly installed, 0 to remove and 36 not upgraded. #0 5.079 Need to get 1614 kB of archives. #0 5.079 After this operation, 5259 kB of additional disk space will be used. #0 5.079 Get:1 http://deb.debian.org/debian buster/main amd64 lsb-base all 10.2019051400 [28.4 kB] #0 5.156 Get:2 http://deb.debian.org/debian buster/main amd64 make amd64 4.2.1-1.2 [341 kB] #0 5.324 Get:3 http://deb.debian.org/debian buster/main amd64 sudo amd64 1.8.27-1+deb10u3 [1244 kB] #0 5.654 debconf: delaying package configuration, since apt-utils is not installed #0 5.696 Fetched 1614 kB in 1s (2661 kB/s) #0 5.736 Selecting previously unselected package lsb-base. (Reading database ... 6674 files and directories currently installed.) #0 5.749 Preparing to unpack .../lsb-base_10.2019051400_all.deb ... #0 5.753 Unpacking lsb-base (10.2019051400) ... #0 5.808 Selecting previously unselected package make. #0 5.810 Preparing to unpack .../make_4.2.1-1.2_amd64.deb ... #0 5.814 Unpacking make (4.2.1-1.2) ... #0 5.936 Selecting previously unselected package sudo. #0 5.938 Preparing to unpack .../sudo_1.8.27-1+deb10u3_amd64.deb ... #0 5.946 Unpacking sudo (1.8.27-1+deb10u3) ... #0 6.129 Setting up lsb-base (10.2019051400) ... #0 6.143 Setting up make (4.2.1-1.2) ... #0 6.157 Setting up sudo (1.8.27-1+deb10u3) ... #0 6.226 invoke-rc.d: could not determine current runlevel #0 6.233 invoke-rc.d: policy-rc.d denied execution of start. #0 6.305 /build/setup.sh: line 57: git: command not found #0 6.311 ======================================== #0 6.311 ROOTDIR=/ #0 6.311 OUT=//out #0 6.311 PRODUCT_OUT=//out/target/product/imx8m_phanbell #0 6.311 HOST_OUT=//out/host/linux-x86 #0 6.311 ROOT_OUT=//out/root #0 6.311 ======================================== #0 6.311 #0 6.311 Type m to build. #0 6.314 make: Entering directory '/build' #0 6.328 Makefile:26: *** qemu-user-static is either not installed or not configured properly.. Stop. #0 6.328 make: Leaving directory '/build' ------ Dockerfile:21 -------------------- 20 | ADD ./board /board 21 | >>> RUN /bin/bash -c '\ 22 | >>> apt-get update && \ 23 | >>> apt-get install -y sudo make && \ 24 | >>> ln -sfr /build/Makefile /Makefile && \ 25 | >>> source /build/setup.sh && \ 26 | >>> make -C /build prereqs' 27 | -------------------- error: failed to solve: process "/bin/sh -c /bin/bash -c 'apt-get update && apt-get install -y sudo make && ln -sfr /build/Makefile /Makefile && source /build/setup.sh && make -C /build prereqs'" did not complete successfully: exit code: 2 make: *** [/home/peterkwon/prj/tinkerBoard_T/build/docker.mk:32: /home/peterkwon/prj/tinkerBoard_T/cache/aiy-board-builder.tar] Error 1 /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dts:32.5-18: Warning (reg_format): /fragment@2/__overlay__/pcm5122@4d:reg: property has invalid length (4 bytes) (#address-cells == 2, #size-cells == 1) /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (pci_device_reg): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (pci_device_bus_num): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (simple_bus_reg): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (i2c_bus_reg): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (spi_bus_reg): Failed prerequisite 'reg_format' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dts:29.24-34.6: Warning (avoid_default_addr_size): /fragment@2/__overlay__/pcm5122@4d: Relying on default #address-cells value /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dts:29.24-34.6: Warning (avoid_default_addr_size): /fragment@2/__overlay__/pcm5122@4d: Relying on default #size-cells value /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (avoid_unnecessary_addr_size): Failed prerequisite 'avoid_default_addr_size' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/hifiberry-dacplus-overlay.dtbo: Warning (unique_unit_address): Failed prerequisite 'avoid_default_addr_size' /home/peterkwon/prj/tinkerBoard_T/packages/uboot-imx/debian/overlays/waveshare_5inch_dsi.dts:10.12-12.6: Warning (unit_address_vs_reg): /fragment@0/__overlay__/panel@0: node has a unit name, but no reg property *** GUI build selected -- set HEADLESS_BUILD=true if this is not what you intend. *** Building packages locally, set FETCH_PACKAGES=true to use prebuilts mkdir -p /home/peterkwon/prj/tinkerBoard_T/cache/docker-build cp -a /home/peterkwon/prj/tinkerBoard_T/build /home/peterkwon/prj/tinkerBoard_T/cache/docker-build cp -a /home/peterkwon/prj/tinkerBoard_T/board /home/peterkwon/prj/tinkerBoard_T/cache/docker-build cp -a /home/peterkwon/prj/tinkerBoard_T/build/Dockerfile /home/peterkwon/prj/tinkerBoard_T/cache/docker-build docker build -t aiy-board-builder /home/peterkwon/prj/tinkerBoard_T/cache/docker-build [+] Building 7.7s (8/8) FINISHED => [internal] load build definition from Dockerfile 0.0s => => transferring dockerfile: 924B 0.0s => [internal] load .dockerignore 0.0s => => transferring context: 2B 0.0s => [internal] load metadata for docker.io/library/debian:10.0 0.9s => [1/4] FROM docker.io/library/debian:10.0@sha256:2f04d3d33b6027bb74ecc81397abe780649ec89f1a2af18d7022737d0482cefe 0.0s => [internal] load build context 0.0s => => transferring context: 3.56kB 0.0s => CACHED [2/4] ADD ./build /build 0.0s => CACHED [3/4] ADD ./board /board 0.0s => ERROR [4/4] RUN /bin/bash -c 'apt-get update && apt-get install -y sudo make && ln -sfr /build/Makefile /Makefile && source /build/setup.sh && make -C /build prereqs' 6.7s ------ > [4/4] RUN /bin/bash -c 'apt-get update && apt-get install -y sudo make && ln -sfr /build/Makefile /Makefile && source /build/setup.sh && make -C /build prereqs': #0 0.573 Get:1 http://security.debian.org/debian-security buster/updates InRelease [34.8 kB] #0 0.675 Get:2 http://deb.debian.org/debian buster InRelease [122 kB] #0 0.877 Get:3 http://deb.debian.org/debian buster-updates InRelease [56.6 kB] #0 0.917 Get:4 http://security.debian.org/debian-security buster/updates/main amd64 Packages [357 kB] #0 1.307 Get:5 http://deb.debian.org/debian buster/main amd64 Packages [7909 kB] #0 2.205 Get:6 http://deb.debian.org/debian buster-updates/main amd64 Packages [8788 B] #0 3.397 Fetched 8488 kB in 3s (2946 kB/s) #0 3.397 Reading package lists... #0 4.089 Reading package lists... #0 4.705 Building dependency tree... #0 4.812 Reading state information... #0 4.917 The following additional packages will be installed: #0 4.917 lsb-base #0 4.917 Suggested packages: #0 4.917 make-doc #0 4.976 The following NEW packages will be installed: #0 4.976 lsb-base make sudo #0 5.169 0 upgraded, 3 newly installed, 0 to remove and 36 not upgraded. #0 5.169 Need to get 1614 kB of archives. #0 5.169 After this operation, 5259 kB of additional disk space will be used. #0 5.169 Get:1 http://deb.debian.org/debian buster/main amd64 lsb-base all 10.2019051400 [28.4 kB] #0 5.244 Get:2 http://deb.debian.org/debian buster/main amd64 make amd64 4.2.1-1.2 [341 kB] #0 5.405 Get:3 http://deb.debian.org/debian buster/main amd64 sudo amd64 1.8.27-1+deb10u3 [1244 kB] #0 5.795 debconf: delaying package configuration, since apt-utils is not installed #0 5.835 Fetched 1614 kB in 1s (2576 kB/s) #0 5.871 Selecting previously unselected package lsb-base. (Reading database ... 6674 files and directories currently installed.) #0 5.883 Preparing to unpack .../lsb-base_10.2019051400_all.deb ... #0 5.887 Unpacking lsb-base (10.2019051400) ... #0 5.943 Selecting previously unselected package make. #0 5.945 Preparing to unpack .../make_4.2.1-1.2_amd64.deb ... #0 5.950 Unpacking make (4.2.1-1.2) ... #0 6.076 Selecting previously unselected package sudo. #0 6.077 Preparing to unpack .../sudo_1.8.27-1+deb10u3_amd64.deb ... #0 6.084 Unpacking sudo (1.8.27-1+deb10u3) ... #0 6.283 Setting up lsb-base (10.2019051400) ... #0 6.297 Setting up make (4.2.1-1.2) ... #0 6.310 Setting up sudo (1.8.27-1+deb10u3) ... #0 6.377 invoke-rc.d: could not determine current runlevel #0 6.386 invoke-rc.d: policy-rc.d denied execution of start. #0 6.459 /build/setup.sh: line 57: git: command not found #0 6.465 ======================================== #0 6.465 ROOTDIR=/ #0 6.465 OUT=//out #0 6.465 PRODUCT_OUT=//out/target/product/imx8m_phanbell #0 6.465 HOST_OUT=//out/host/linux-x86 #0 6.465 ROOT_OUT=//out/root #0 6.465 ======================================== #0 6.465 #0 6.465 Type m to build. #0 6.468 make: Entering directory '/build' #0 6.483 make: Leaving directory '/build' #0 6.483 Makefile:26: *** qemu-user-static is either not installed or not configured properly.. Stop. ------ Dockerfile:21 -------------------- 20 | ADD ./board /board 21 | >>> RUN /bin/bash -c '\ 22 | >>> apt-get update && \ 23 | >>> apt-get install -y sudo make && \ 24 | >>> ln -sfr /build/Makefile /Makefile && \ 25 | >>> source /build/setup.sh && \ 26 | >>> make -C /build prereqs' 27 | -------------------- error: failed to solve: process "/bin/sh -c /bin/bash -c 'apt-get update && apt-get install -y sudo make && ln -sfr /build/Makefile /Makefile && source /build/setup.sh && make -C /build prereqs'" did not complete successfully: exit code: 2 make: *** [/home/peterkwon/prj/tinkerBoard_T/build/docker.mk:32: /home/peterkwon/prj/tinkerBoard_T/cache/aiy-board-builder.tar] Error 1 -------------------------------------------------------------------------- build Message End ---------------------------------------------------------------------- I want to know how to fix the error. Regard.
  3. Kernel Build Questions in Tinker Edge T I installed Mendel 5 Eagle V3.0.2 on Tinker Edge T. I want to change Boot Logo of Tinker Edge T, and I want to communicate with UART device in Mendel Linux. To change the Boot Logo, Kernel must be compiled. Where can I download the kernel source for Mendel 5 Eagle V3.0.2? And, what do I need to do to communicate with the UART device in mendel linux? Guid documentation says /dev/ttymxc0 and /dev/ttymxc2 should exist, but I see /dev/ttymxc0 and /dev/ttymxc1. If /dev/ttymxc1 is checked, it is said to be incorrect. I need help with the above two. regards.
  4. Kernel Build Questions in Tinker Edge T I installed Mendel 5 Eagle V3.0.2 on Tinker Edge T. I want to change Boot Logo of Tinker Edge T, and I want to communicate with UART device in Mendel Linux. To change the Boot Logo, Kernel must be compiled. Where can I download the kernel source for Mendel 5 Eagle V3.0.2? And, what do I need to do to communicate with the UART device in mendel linux? Guid documentation says /dev/ttymxc0 and /dev/ttymxc2 should exist, but I see /dev/ttymxc0 and /dev/ttymxc1. If /dev/ttymxc1 is checked, it is said to be incorrect. I need help with the above two. regards.
  5. Hi guys I want to know how to change the Booting Logo of Tinker Edge T. Please tell me how to change u-boot's booting logo and kernel's booting logo.
  6. My tinker edge t board has two UARTs, ttymxc0 and ttymcx1. If you don't see ttymxc2 in the get start documentation, it says to do sudo apt-get dist-upgrade. However, ttymxc2 is not visible even after rebooting after sudo apt-get dist-upgrade. When ttymxc0 and ttymxc1 are opened for UART communication, communication is not possible, so I want to know what to do to enable uart communication. Regards
  7. Hello guys! UART communication is attempted. If you look at the GetStart document, ttymxc0 and ttymxc2 should be in the Uart list, but ttymxc0 and ttymxc1 appear in my Edge T device. So, all UART Opens fail. What prerequisites should be done for UART communication? Thank.
  8. Hi guys. I want to know how to install libedgetpu library. I'm trying to make inferences using C language, but I can't find edgetpu.h or edgetpu_c.h. So, I want to know how to install libedgetpu for C/C++ language. regards.
×
×
  • Create New...