Jump to content


  • Content Count

  • Joined

  • Last visited

Community Reputation

0 Neutral
  1. I can, just to know the behaviour, but in production we deliver it to customer without the SD Card with the OS on the eMMC 😞
  2. I just got and tried a new, second one (same model, Tinker Board 3N). Removed the jumper cap, plugged into the mac and it immediately recognized and works like a charm. Looks like the first one needs to be RMA. Thanks
  3. Thanks for all the great feedback. There is always an option it's a faulty one.
  4. I'm not sure I understand the last question, but I've never "used" the board in term of booting the OS. As soon as I plug in the power supply, red led turns on. It was on also before I've removed the mask2 jumper. So, it's always on when I connect the power supply, no matter if USB cable is connected or not.
  5. I've attached the latest setup photo for reference. Red light is there, USB-C -> USB-A, but nothing detected by Win, and nothing in device manager.
  6. I've done all that, both jumper caps removed, except Macbook does not have USB-A port, so have to use USB hub for that. Also tried on Windows, which now does not recognize anything at all 😞
  7. Thanks for really fast answers. Unfortunatelly... still nothing. So, I've removed jumper from Mask2 pins. What about the Recovery pins, should I have the jumper there ON or no)? And also the Mask1 dip-switch?
  8. Thanks for the feedback. On Mac I had to use USB Hub to get USB-A port. Tried two without any success. Result is the same. Then I tried on the Windows machine and it got recognized, but not as a storage device, but as "Unknown Device", which then was not available for flashing in BalenaEther as it's not recognized as a storage device. Any further help please? Is there any drivers I should install on Win? Thanks again
  9. After successfully using TinkerBoard 2S in production, we wanted to evaluate TinkerBoard 3N and bought it. However, using the same setup (macOS and USB-C <-> USB-C cable directly connected to the mac laptop), we cannot get it to be recognized as a storage device. We're following the same procedure as we do with the TinkerBoard 2S (unplug everything from TinkerBoard, connect the USB-C cable to board and laptop using the OTG port and then connecting the power supply. But nothing happens when we connect the board... Can you suggest what can we try to resolve the issue? Photo of the board itself is attached if that helps in any way... Thanks
  10. Yup, my question is kinda pointless... we are changing the baudrate in user space, and it's working properly. The issue was somewhere else, not related to TinkerBoard itself (we've resolved that). Thanks
  11. Thanks for prompt reply. I'll check the fix and get back here with the result. Hopefully we will have this fix included in next official Debian11 image too.
  12. Thanks for the response. These are exact steps for reproduction: 1) burn official 3.0.11 image (Tinker_Board_2-Debian-Bullseye-v3.0.11-20231024-release.img) 2) change intf:fiq_debugger to OFF 3) change intf:uart0 to ON 4) remove wifi/bt card that was shipped with the TinkerBoard 5) Reboot When I put back the WiFi/BT card in, then I can see the line: cfg80211: failed to load regulatory.db but without wireless card, it's stuck on boot just before that line (as shown on photo). Best regards
  13. Hello, When. in /boot/config.txt I enable uart0 and uart4 and define them with different baud rates, both are always initialized with 1500000 baudrate. intf:fiq_debugger=on intf:uart0=on intf:uart4=on #intf:i2c6=off #intf:i2c7=off #intf:i2s0=off #intf:spdif=on #intf:spi1=off #intf:spi5=off #intf:pwm0=off #intf:pwm1=off #intf:pwm3a=off #intf:test_clkout2=off uart0 = Serial("/dev/ttyS0", 115200) uart4 = Serial("/dev/ttyS4", 1000000) then after the boot I get: linaro@linaro-alip:~$ sudo dmesg | grep tty [ 4.664967] Kernel command line: storagemedia=emmc androidboot.storagemedia=emmc androidboot.mode=normal androidboot.verifiedbootstate=orange androidboot.serialno=b6977d7c12b9a2e5 root=/dev/mmcblk0p8 rw rootwait console=tty0 earlycon=uart8250,mmio32,0xff1a0000 console=ttyFIQ0 rootfstype=ext4 coherent_pool=1m [ 5.325828] printk: console [tty0] enabled [ 5.681796] Registered FIQ tty driver [ 6.876158] printk: console [ttyFIQ0] enabled [ 6.890795] Registered fiq debugger ttyFIQ0 [ 7.667771] ff180000.serial: ttyS0 at MMIO 0xff180000 (irq = 45, base_baud = 1500000) is a 16550A [ 7.668238] ff370000.serial: ttyS4 at MMIO 0xff370000 (irq = 47, base_baud = 1500000) is a 16550A [ 14.656870] ttyFIQ ttyFIQ0: tty_port_close_start: tty->count = 1 port count = 2 How to change baudrate this? Thanks
  14. Hello, When we put "intf:fiq_debugger=off" line to config.txt and removed WiFi card (as the device we're sending to our customers does not require WiFi/BT, TInkerBoard simply won't boot. It's stuck after the messages about cfg80211 loading certificates (as shown in the attached photo). Do you have maybe any solution or workaround for this issue? Best regards, Jovan
  • Create New...