Jump to content

Cannot install Android on Tinkerboard S

Recommended Posts



I'm new to the forum.  I've looked around, but can't find this specific issue covered elsewhere.

I can flash and install TinkerOS, but not Android.

I've tried various PSUs and USB cables, and different monitors. So those are unlikely to be the issue (all PSUs giving at least 2.4A, all cables short).

Steps to flash:

Using Tinker Board model S. Brand new, just purchased.

Download Android image (I've tried all version that I can find, from this site, and various others)

Use balenaEtcher on OSX to flash image to a 128Gb Sandisk SD card

Get warning  about there being "missing partition table" (I get this with all Android images, do not get it with Debian)

Insert card into Tinker

Power on


I get literally nothing ... just the red light. Nothing on HDMI.

Follow exactly the same steps, but use a Debian image... works fine.



Any ideas?










Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...