Jump to content

Artefacts in kernel boot log

Recommended Posts

I noticed that at some point of the TinkerBoard 2 start-up, the uboot log starts getting corrupted and continue to be like that until later the kernel initialise some serial devices when it gets back to normal. Does anyone have an idea what is causing this and how to fix it? I'm running the latest Debian image Tinker_Board_2-Debian-Buster-v2.0.4-20211222 but also tried v2.0.3 with the same result.

Set GPIO2_A4 (MASK_RELEASE) output high
no mmc device at slot 1
Found IDB in SDcard
dwmmc@fe320000: 1 (SD), sdhci@fe330000: 0
Bootdev(atags): mmc 1
MMC1: Legacy, 50Mhz
PartType: EFI
boot mode: None
Found DTB in boot part
DTB: rk-kernel.dtb
I2c0 speed: 400000Hz
vdd_center 900000uV
vdd_c`u_l9     uV
vdd_log9     uV
Rockchi`UBOOTDRMdriverversion:v1. .1
CLK:(uboot.arml:enter816   KHz,init816   KHz,kernel N/)
CLK:(uboot.armb:enter816   KHz,init816   KHz,kernel N/)
a`lll816   KHz
a`llb816   KHz
d`ll856   KHz
c`ll24   KHz
g`ll8     KHz
n`ll6     KHz
v`ll24   KHz
aclk_`eril` 266666KHz
hclk_`eril` 88888KHz
`clk_`eril` 44444KHz
hclk_`eril`11     KHz
`clk_`eril`15    KHz
Hitkeytosto`autoboot('CTR +1'2:3
fdtmagicnumberedfe dd
fdtsize1 48576


Share this post

Link to post
Share on other sites

hello @Adam

we've tried to reproduce the issue with debian 10 v.2.0.3 and v.2.0.4 but it didn't occur in both os versions. is the serial frequency set to 115200? if so, perhaps there's something happened during the flash, or the sigal of cable isn't stable. we'd suggest to 1. reflash the image and/or 2. use another cable and try if it fixes the problem.


Share this post

Link to post
Share on other sites

hi @tooz

Please take a look at direct capture of console tx line from tinkerboard. The logic analyser is set to decode UART at 115200bps and it decodes correctly at the beginning of the boot (see image #1) then it goes wrong (image #2) and goes back to correct (image #3)

It looks like the UART clock if drifting away causing character and frame errors. This problem exists in all 3 tinkerboard2 units we have and with different debian images (2.0.3 and 2.0.4).

#1 image.png

 #2 image.png  

#3 image.png

Share this post

Link to post
Share on other sites

Also, below is a similar topic, so the problem seems to be common. 



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...