Jump to content
skuenstler

WiFi not working with BalenaOS Debian Linux

Recommended Posts

Posted (edited)

Hi, 

  I tried to get WiFi running using BalenaOS (image balenaOS 2.38.3+rev1) following the Balena setup manual

But WiFi is not working.

Any help on this ?

What I tried A), B) or C) see as follows...

But unfortunately, none of the trials A, B or C helped 😞

Do you have any idea on how to get the WiFi running using the balenaOS.2.38+rev1 image ????

 

Trial A) using the file system-connections/balena-wifi-01 in the flash-boot of the BalenaOS image

[connection]
id=balena-wifi-01
type=wifi

[wifi]
hidden=false
mode=infrastructure
ssid=MY_SSID

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto

[wifi-security]
auth-alg=open
key-mgmt=wpa-psk
psk=MY_PW

 

Trial B) As described in flash-boot's system-connections/README.ignores file, I took away the .ignores of the resin-sample File. But this seems an old way of doing things. Not sure about this.

[connection]
id=resin-sample
type=wifi

[wifi]
hidden=true
mode=infrastructure
ssid=MY_SSID

[wifi-security]
auth-alg=open
key-mgmt=wpa-psk
psk=MY_PW

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto

Trial C) entering WiFi/PW credentials in flash-boot's device-type.json

{
    "slug": "asus-tinker-board-s",
    "version": 1,
    "aliases": [
        "asus-tinker-board-s"
    ],
    "name": "Asus Tinker Board S (EXPERIMENTAL)",
    "arch": "armv7hf",
    "state": "EXPERIMENTAL",
    "stateInstructions": {
        "postProvisioning": [
            "The device is performing a shutdown. Please wait until all LEDs are off.",
            "Remove the balenaOS installation media.",
            "Before powering up the Asus Tinker Board S, make sure that the jumper between the 5V power supply and the HDMI connector is in the parking (no function) mode, as ilustrated in this link https://tinkerboarding.co.uk/wiki/index.php/Setup",
            "Remove and re-connect power to the board."
        ]
    },
    "instructions": [
        "Write the OS file you downloaded to your SD card. We recommend using <a href=\"http://www.etcher.io/\">Etcher</a>.",
        "Insert the freshly burnt SD card into the Asus Tinker Board S.",
        "<strong role=\"alert\">Warning!</strong> This will also completely erase internal storage media, so please make a backup first.",
        "Before powering up the Asus Tinker Board S, make sure that the jumper between the 5V power supply and the HDMI connector is in the MASKROM mode, as ilustrated in this link https://tinkerboarding.co.uk/wiki/index.php/Setup",
        "The device is performing a shutdown. Please wait until all LEDs are off.",
        "Remove the balenaOS installation media.",
        "Before powering up the Asus Tinker Board S, make sure that the jumper between the 5V power supply and the HDMI connector is in the parking (no function) mode, as ilustrated in this link https://tinkerboarding.co.uk/wiki/index.php/Setup",
        "Remove and re-connect power to the board."
    ],
    "gettingStartedLink": {
        "windows": "https://docs.resin.io/asus-tinker-board-s/nodejs/getting-started/#adding-your-first-device",
        "osx": "https://docs.resin.io/asus-tinker-board-s/nodejs/getting-started/#adding-your-first-device",
        "linux": "https://docs.resin.io/asus-tinker-board-s/nodejs/getting-started/#adding-your-first-device"
    },
    "supportsBlink": true,
    "yocto": {
        "machine": "asus-tinker-board-s",
        "image": "resin-image-flasher",
        "fstype": "resinos-img",
        "version": "yocto-sumo",
        "deployArtifact": "resin-image-flasher-asus-tinker-board-s.resinos-img",
        "compressed": true
    },
    "options": [
        {
            "isGroup": true,
            "name": "network",
            "message": "Network",
            "options": [
                {
                    "message": "Network Connection",
                    "name": "network",
                    "type": "list",
                    "choices": [
                        "wifi"
                    ]
                },
                {
                    "message": "Wifi SSID",
                    "name": "MY_WIFI",
                    "type": "text",
                    "when": {
                        "network": "wifi"
                    }
                },
                {
                    "message": "Wifi Passphrase",
                    "name": "MY_PW",
                    "type": "password",
                    "when": {
                        "network": "wifi"
                    }
                }
            ]
        },
        {
            "isGroup": true,
            "isCollapsible": true,
            "collapsed": true,
            "name": "advanced",
            "message": "Advanced",
            "options": [
                {
                    "message": "Check for updates every X minutes",
                    "name": "appUpdatePollInterval",
                    "type": "number",
                    "min": 10,
                    "default": 10
                }
            ]
        }
    ],
    "configuration": {
        "config": {
            "partition": {
                "primary": 1
            },
            "path": "/config.json"
        }
    },
    "initialization": {
        "options": [
            {
                "message": "Select a drive",
                "type": "drive",
                "name": "drive"
            }
        ],
        "operations": [
            {
                "command": "burn"
            }
        ]
    }

}
 

Edited by skuenstler

Share this post


Link to post
Share on other sites

I snapped the two antenna wires to the board and my wifi worked.  Without those connected it would not see anything.

Share this post


Link to post
Share on other sites

I cannot make the wifi to work as a hotspot. This is using the standard Linux image setup, nothing fancy. I cannot make it work for S R2.0 and for the 2S. Antennas or not antennas. Frustrating.

Share this post


Link to post
Share on other sites

Access point UP and this is the sequence of negotiation and them refusal (timeout?)

Sep 21 16:03:31 OEI-XXXX kernel: RTW: ============ STA [88:66:5a:11:3e:e1]  ===================
Sep 21 16:03:31 OEI-XXXX kernel: RTW: mac_id : 0
Sep 21 16:03:31 OEI-XXXX kernel: RTW: wireless_mode : 0x0b
Sep 21 16:03:31 OEI-XXXX kernel: RTW: mimo_type : 2
Sep 21 16:03:31 OEI-XXXX kernel: RTW: static smps : N
Sep 21 16:03:31 OEI-XXXX kernel: RTW: bw_mode : 20MHz, ra_bw_mode : 20MHz
Sep 21 16:03:31 OEI-XXXX kernel: RTW: rate_id : 2
Sep 21 16:03:31 OEI-XXXX kernel: RTW: rssi : -1 (%), rssi_level : 0
Sep 21 16:03:31 OEI-XXXX kernel: RTW: is_support_sgi : Y, is_vht_enable : N
Sep 21 16:03:31 OEI-XXXX kernel: RTW: disable_ra : N, disable_pt : N
Sep 21 16:03:31 OEI-XXXX kernel: RTW: is_noisy : N
Sep 21 16:03:31 OEI-XXXX kernel: RTW: txrx_state : 0
Sep 21 16:03:31 OEI-XXXX kernel: RTW: curr_tx_rate : CCK_1M (L)
Sep 21 16:03:31 OEI-XXXX kernel: RTW: curr_tx_bw : 20MHz
Sep 21 16:03:31 OEI-XXXX kernel: RTW: curr_retry_ratio : 0
Sep 21 16:03:31 OEI-XXXX kernel: RTW: ra_mask : 0x000000000fffffff
Sep 21 16:03:31 OEI-XXXX kernel: RTW: send eapol packet 1/4
Sep 21 16:03:31 OEI-XXXX kernel: RTW: set group key camid:1, addr:00:00:00:00:00:00, kid:1, type:TKIP
Sep 21 16:03:31 OEI-XXXX kernel: RTW: recv eapol packet 2/4
Sep 21 16:03:31 OEI-XXXX kernel: RTW: send eapol packet 3/4
Sep 21 16:03:31 OEI-XXXX kernel: RTW: recv eapol packet 4/4
Sep 21 16:03:31 OEI-XXXX kernel: RTW: set pairwise key camid:4, addr:88:66:5a:11:3e:e1, kid:0, type:AES
Sep 21 16:03:37 OEI-XXXX kernel: RTW: OnDisassoc(wlp1s0) reason=8, ta=88:66:5a:11:3e:e1
Sep 21 16:03:37 OEI-XXXX kernel: RTW: clear key for addr:88:66:5a:11:3e:e1, camid:4
Sep 21 16:03:38 OEI-XXXX kernel: RTW: ============ STA [88:66:5a:11:3e:e1]  ===================
Sep 21 16:03:38 OEI-XXXX kernel: RTW: mac_id : 0
Sep 21 16:03:38 OEI-XXXX kernel: RTW: wireless_mode : 0x0b
Sep 21 16:03:38 OEI-XXXX kernel: RTW: mimo_type : 2
Sep 21 16:03:38 OEI-XXXX kernel: RTW: static smps : N
Sep 21 16:03:38 OEI-XXXX kernel: RTW: bw_mode : 20MHz, ra_bw_mode : 20MHz
Sep 21 16:03:38 OEI-XXXX kernel: RTW: rate_id : 2
Sep 21 16:03:38 OEI-XXXX kernel: RTW: rssi : -1 (%), rssi_level : 0
Sep 21 16:03:38 OEI-XXXX kernel: RTW: is_support_sgi : Y, is_vht_enable : N
Sep 21 16:03:38 OEI-XXXX kernel: RTW: disable_ra : N, disable_pt : N
Sep 21 16:03:38 OEI-XXXX kernel: RTW: is_noisy : N
Sep 21 16:03:38 OEI-XXXX kernel: RTW: txrx_state : 0
Sep 21 16:03:38 OEI-XXXX kernel: RTW: curr_tx_rate : CCK_1M (L)
Sep 21 16:03:38 OEI-XXXX kernel: RTW: curr_tx_bw : 20MHz
Sep 21 16:03:38 OEI-XXXX kernel: RTW: curr_retry_ratio : 0
Sep 21 16:03:38 OEI-XXXX kernel: RTW: ra_mask : 0x000000000fffffff
Sep 21 16:03:38 OEI-XXXX kernel: RTW: send eapol packet 1/4
Sep 21 16:03:38 OEI-XXXX kernel: RTW: recv eapol packet 2/4
Sep 21 16:03:38 OEI-XXXX kernel: RTW: send eapol packet 3/4
Sep 21 16:03:38 OEI-XXXX kernel: RTW: recv eapol packet 4/4
Sep 21 16:03:38 OEI-XXXX kernel: RTW: set pairwise key camid:4, addr:88:66:5a:11:3e:e1, kid:0, type:AES
Sep 21 16:03:44 OEI-XXXX kernel: RTW: OnDeAuth(wlp1s0) reason=15, ta=88:66:5a:11:3e:e1
Sep 21 16:03:44 OEI-XXXX kernel: RTW: clear key for addr:88:66:5a:11:3e:e1, camid:4
Sep 21 16:04:00 OEI-XXXX kernel: invalid destination resolution act_w = 0, act_h = 0
 

Share this post


Link to post
Share on other sites

have you login as root and see if it will work?  Log off and then as root.

I never used tinkerboard as a hot spot. I use my cellphone and tethering in the setting.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...