Jump to content

Finding the solution to install ROS and get UART working

Recommended Posts

I am currently attempting to use a TinkerBoard2S as a rosbag recorder for various sensors,
and I am encountering a few issues.

Here are my requirements:

  1. I need to install ROS on the TinkerBoard2S.
  2. I need to be able to read UART for IMU data.

Initially, I attempted to install the complete ROS system via a simple deb installation, but I ran into issues because ROS does not support Debian10 well. I then tried to follow the instructions on this page (https://github.com/lawkee48/TinkerOS-ROS), which allowed me to run roscore, but I encountered a problem when trying to compile the PCL library for my Velodyne sensor, as it took too long.

Next, I tried installing Ubuntu20 on the TinkerBoard2S, which made it easy to install the full ROS system. However, I am now unsure how to enable the UART port on the Ubuntu20 system. I know that for the TinkerBoard2S, I only need to set /boot/config.txt and set the intf:uart0=on. After rebooting, the ttyS0 should be mounted as the UART port.

Any suggestions on how to proceed would be greatly appreciated. Thank you!

Untitled Diagram.drawio.png

Share this post

Link to post
Share on other sites

hello @jjj44

here are the commands to install ros (ros-noetic-desktop) -- verified it can be installed in debian 10 v.2.1.6 / 2.0.14

wget http://ftp.us.debian.org/debian/pool/main/g/gmp/libgmp10_6.1.2+dfsg-4+deb10u1_arm64.deb
wget http://ftp.us.debian.org/debian/pool/main/n/nettle/libhogweed4_3.4.1-1+deb10u1_arm64.deb
wget http://ftp.us.debian.org/debian/pool/main/n/nettle/libnettle6_3.4.1-1+deb10u1_arm64.deb
wget http://security.debian.org/debian-security/pool/updates/main/g/gnutls28/libgnutls30_3.6.7-4+deb10u10_arm64.deb
sudo dpkg -i libgmp10_6.1.2+dfsg-4+deb10u1_arm64.deb
sudo dpkg -i libhogweed4_3.4.1-1+deb10u1_arm64.deb
sudo dpkg -i libnettle6_3.4.1-1+deb10u1_arm64.deb
sudo dpkg -i libgnutls30_3.6.7-4+deb10u10_arm64.deb
sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-key C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654
sudo apt update
sudo apt install ros-noetic-desktop


*notices like these are expected and can be ignored:

ldconfig: file /usr/lib/mali/libmali.so is truncated

ldconfig: file /usr/lib/mali/libmali.so.1.9.0 is truncated

ldconfig: file /usr/lib/mali/libmali.so.1 is truncated

ldconfig: file /usr/lib/mali/libmali-midgard-t86x-r18p0-x11.so is truncated

ldconfig: file /usr/lib/libmali.so.1 is truncated

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...