Jump to content
Sign in to follow this  

Problem with USB Webcam

Recommended Posts

Hello, i tried using my Webcam on the latest Debian 10 version on my Tinker Board.

Unfortunately it does not get detected as UVC device, which it should. On another Laptop it works fine in Linux.

Now i dont know why uvcvideo (the Kernel driver) does not detect this cam.

it is listed with lsusb. The ID is 17ef:482f

Is there anything i can do to get it working?

I tried to recompile the kernel as the uvcvideo is compiled into the kernel. But i dont get very far with the Tutorial from https://github.com/TinkerBoard/TinkerBoard/wiki/Developer-Guide

the error i get is when trying to "sudo apt-get install gnupg-agent"

The following packages have unmet dependencies:
 gnupg-agent : Depends : gpg-agent (>= 2.2.12-1+deb10u2) but 2.2.12-1+deb10u1 is to be installed


i dont know what route to take. It seems this debian version is broken in some way. Maybe you can point me to another distribution or some solution to my webcam problem?


many greetings,


Share this post

Link to post
Share on other sites

hello @Buchhalter

1. was the usb camera working with the previous os releases?

2. what’s the usb camera you’re using?

3. what’s the output when you execute 

v4l2-ctl --list-devices


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...