Jump to content

Disabling i2c

Recommended Posts

Hi everyone.

I was using TinkerBoard S boards for a project, but now that we can't get those anywhere, I started looking for other solutions.

I didn't want to use anything that didn't have an EMMC, so I went the Tinker Edge T route while waiting for the S2 to come out.

I can get pretty much everything I need working, but I can't seem to be able to disable the i2c bus at all. I need to disable it to be able to use at least 25 GPIO.

I tried the /boot/config.txt route, but not only are i2c busses not listed originally, adding them manually (with intf:i2c2=off) doesn't disable them at all. Moreover, there doesn't seem to be any linux kernel loaded for it.

I am using the Tinker Edge T with Mendel Eagle 3.0.7.

Any way for me to disable i2c ?

Thank you !

Share this post

Link to post
Share on other sites

hello @Weby

The design of Tinker Edge T doesn't allow i2c to be disabled. Tinker Edge T's USB and i2c2 shared the same channel, once i2c is disabled, the user will not be able to have USB working. 

Share this post

Link to post
Share on other sites


Thank you. That's very disconcerting though. The documentation of the device states that we can use "up to 28 GPIO", implying that all the GPIOs can have their other functions disconnected from it.

Would the answer change if I reformulate my question to : is it possible to disconnect the i2c feature from the GPIO pins so I can use those pins for other purposes ?

Thank you again !

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...