Jump to content
Sign in to follow this  

Can't work USB WebCamera

Recommended Posts

I have some USB Web Camera (UVC), but all of them doesn't work.
Do I need to make any settings to be able to use the webcam?


[ Testing environment ]

Tinker board 2S

(1)Debian10 v2.0.14

(2)Debian v2.1.6

I tried both OS as clean installed environment.


(a)Pre-installed "Cheese" Application

(b)Pre-installed "Qt V4L2 test Utility" Application



(1) and (2) are same result.


Normaly, /dev/video0 ~ video4 are appears.

Then pluged the USB Web Camera, /dev/video5 and /dev/video6 are added.

$ v4l2-ctl -d /dev/video5 -all

video5 seems video device, and video6 seems other device.


(a) : Shows "There wan an error playing video from the webcam" Error. 

   Probably auto selected video0 as a default device.    

    There should be a preferences menu in the Cheese app and can select video5, but the settings menu can't be displayed (probably a bug)


(b):File > Open Device > device5, then crashed application and desktop...






Share this post

Link to post
Share on other sites

hello @Poko-san

i've used tinker board 2s with debian 10 v.2.0.14

installed qv4l2 test utility, cheese and vlc - there's some compatibility that i cannot use cheese to take/ preview photos or videos

using qv4l2:

open qv4l2 -> open device -> select video5 -> start capturing

uvc running successfully

i've tried using vlc media player:

open media -> capture device -> video device name '/dev/video5' in my case

and it works too

what's the usb video camera you're using?

i'll look into the issues happened in cheese too, but if it's a compatibility limitation, we'd suggest to use another package 



Share this post

Link to post
Share on other sites

hello @Poko-san

we've used v.2.1.6 & v.2.0.14 for uvc testing, 

using cheese:

you will have to switch to usb camera first, to do so, please use the "Camera Product Name"

1. you can check the Product Name with the following command in lxterminal: 

$ udevadm info /sys/class/video4linux/video5 | grep ID_V4L_PRODUCT
ID_V4L_PRODUCT=Logitech Webcam C930e

in this case the Camera Product Name is "Logitech Webcam C930e"

2. then you can open the camera with the command:

$ cheese -d “Logitech Webcam C930e”

we've tested 1080p/480p MJPG & YUYV configs with qv4l2 and both configs work.

may we know which usb cam you're using and the configs?

we've used another unknown branded usb web cam and have noticed that unstable connection can lead to failure such as

cheese:1291): cheese-WARNING **: 10:17:11.512: Failed to allocate required memory.: gstv4l2src.c(658): gst_v4l2src_decide_allocation (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin29/GstV4l2Src:v4l2src2:

Buffer pool activation failed


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...