Jump to content


Popular Content

Showing content with the highest reputation since 06/08/20 in Posts

  1. 3 points
    could you guys release 1 for kernel 5.15.x please? or share how we can compile our own kernels?
  2. 2 points
    Hi guys. Let me share Android 11 for Tinkerboard / Tinkerboard S 1-st revision (not R2.0) which Asus marked as outdated/legacy. You can find download link below: Download Android 11 ROM Tinkerboard (not R2.0) Bug reporting are welcome. Release is based on official Asus firmware for Tinkerboard S R2.0.
  3. 2 points
    Hi everybody, Recently, I have been trying to run some bare metal code on my Tinker Board 2. I managed to compile ARM Trusted Firmware - A successfully with these commands: % git clone https://github.com/ARM-software/arm-trusted-firmware.git tf-a % cd tf-a % export CROSS_COMPILE=~/Developer/Toolchains/aarch64-none-elf/bin/aarch64-none-elf- % make PLAT=rk3399 After that, I tried to build U-Boot with these commands (the CROSS_COMPILE variable is set from previous commands): % git clone https://github.com/TinkerBoard2/u-boot.git uboot % cd uboot % export BL31=../tf-a/build/rk3399/release/bl31/bl31.elf % export KBUILD_OUTPUT=build % make tinker2_defconfig % make This, unfortunately failed with this error: DTC arch/arm/dts/rk3036-sdk.dtb Error: arch/arm/dts/.rk3036-sdk.dtb.pre.tmp:77.1-10 syntax error FATAL ERROR: Unable to parse input tree I tried to fix the problem, and I thought removing 'rk3036-sdk.dtb' from 'arch/arm/dts/Makefile' could work since it seemed to be the device tree of another board that I was building for, which happened to be ill formed. That made the problem disappear, but the same thing happened for 'rk3368-lion.dtb', 'rk3368-sheep.dtb' and a couple of other device trees. I removed them all (7 in total) and the build finally succeeded. I then created a GPT disk image, with a single FAT32 partition with my code compiled, in it. The partition started at sector 18405, so there should have been plenty space for U-Boot. I verified with gdisk that my disk image is not corrupt, so that is clearly not the problem. I tried writing U-Boot into the SD card with the instructions in https://github.com/u-boot/u-boot/blob/master/doc/README.rockchip and https://github.com/u-boot/u-boot/blob/master/doc/board/rockchip/rockchip.rst. Packaging with rockchip miniloader did kind of work, but it printed some unusual characters (Chinese or Japanese?) and a lot of diamonds with single question mark in them at the beginning, and I had to set the baud rate to 120000 to view the output properly. Using U-Boot SPL and U-Boot TPL + SPL only printed one diamond with a question mark in it. I also tried the method provided as an answer to this post, but that did not work, probably because it was for eMMC. I used this command to see if it worked: minicom -D /dev/cu.usbserial-1440 -b 115200 -o I connected my serial to USB cable as instructed in this post I am sure my board is not broken as I was able to run the official Debian image without U-Boot printing any weird characters or problems with baud rate. I wonder, if any Tinker Board engineers could share how U-Boot is built when preparing the official image. Any help is appreciated.
  4. 2 points
    I was able to update Asus's debian to latest version by adding deb http://ftp.us.debian.org/debian testing main contrib non-free to /etc/apt/sources.list.d and then run "sudo apt update" "sudo apt upgrade" but... Disappointed with support level, Asus almost no activity, several questions not answered, software outdated etc
  5. 1 point
    hello @Jovan, was the led (led1) on while using? please check if you're able to use the adb with mask2 cap on while booting?
  6. 1 point
    hello @Jovan, please remove the yellow jumper cap, and re-do the procedure (connecting tinker board 3n to the computer) again booting without the jumper cap attached so the tinker board 3n can start on uboot and the board should be in ums mode
  7. 1 point
    hello @zain, here are some examples for your reference: https://github.com/rockchip-linux/rknn-toolkit/tree/master/examples/mxnet/fcn_resnet101 you can also check chapter 7.15 Export a segmentation model from 02_Rockchip_User_Guide_RKNN_Toolkit_V1.7.5_EN.pdf
  8. 1 point
    thank you sir, @tooz! mraa works normally. Thank you very much.
  9. 1 point
    hello all, my colleague has come up with a little python library called stkcam, that can be used to either to see the live preview of the mipi csi camera, or to take a picture with the mipi csi camera pypi: https://pypi.org/project/stkcam/ github: https://github.com/harryliou/stkcam so far it's supported on tinker board (r2.0) & tinker board 2s (debian 10, debian 11) here's a little how-to: ##setting up tinker board/ tinker board 2s use tinker-config to change the csi overlay: sudo tinker-config //select 5 Interfacing Options //select F1 Camera //select 0 IMX219 //or 1 OV5647 for Raspberry Camera V1 //click Ok, finish, and reboot install pip3 for python3 and stkcam: sudo apt get update sudo apt-get upgrade sudo apt-get install python3-pip pip3 install stkcam ##using stkcam for mipi csi camera live preview: python3 import stkcam from stkcam import TKCam, CamType cam = TKCam(CamType.IMX219) cam.preview() **if you'd like to take a photo using the library, please finish the process first -- exiting by ctrl + d twice) ##using stkcam to take a photo with mipi csi camera: python3 import stkcam from stkcam import TKCam, CamType cam = TKCam(CamType.IMX219) cam.take_image('/home/linaro/Desktop/image.jpg') # image path feel free to give it a try and let us know
  10. 1 point
    hello @Jovan, modifying /boot/config.txt only allows the function to be enabled these are uart driver init loggings baud rates can be changed in user space
  11. 1 point
    hello @captain kirk, also please use sudo tinker-config
  12. 1 point
    hello @gavin67890, for csi cameras, the coral camera is the only camera module supported on tinker edge t thus far: https://tinker-board.asus.com/download/Tinker_Edge_T_Device_QVL.pdf though there's no qvl for the uvc cameras, we use logictec c930e for testing
  13. 1 point
    hello @wahaha, we'll upload the codes by the end of this week, i'll leave a comment with the url once it's done. sorry for the inconvenience.
  14. 1 point
    hello @Tolga, please refer to the setting below. It’s not necessary to use uart1, uart2 or uart4 can be used, too. Using uart3 however is not suggested, since it’s used for uart log output https://github.com/TinkerBoard/TinkerBoard/wiki/User-Guide#gpio-config-table-for-tinker-board-and-tinker-board-s First, modify the /boot/config.txt file as follows, and then reboot to enable I2C1 and I2C4. ##### Hardware Interface Config ####### Note: fiq_debugger and uart3 use the same pin. Set fiq_debugger first while bb oth on. ## ## Note: uart4 and spi0 are the same pins. Set the latter one while both on. ## ## Note: uart2 is the same pins to pwm2 and pwm3. Set the latter one while both on. ## intf:fiq_debugger=on intf:i2c1=on intf:i2c4=on #intf:spi0=off #intf:spi2=off #intf:pwm2=off #intf:pwm3=off intf:pcm_i2s=on intf:uart1=on #intf:uart2=off #intf:uart3=off #intf:uart4=off Chip,line Device Path GPIO number Function2 Function1 GPIO Pin# Pin# GPIO Function1 Function2 GPIO number Device Path Chip,line --- --- --- --- VCC3.3V_IO --- 1 2 --- VCC5V_SYS --- --- --- --- 8,4 GPIO:/sys/class/gpio/gpio252 I2C:/dev/i2c-1 252 --- I2C1_SDA GPIO8_A4 3 4 --- VCC5V_SYS --- --- --- --- 8,5 GPIO:/sys/class/gpio/gpio253 I2C:/dev/i2c-1 253 --- I2C1_SCL GPIO8_A5 5 6 --- GND --- --- --- --- 0,17 GPIO:/sys/class/gpio/gpio17 17 --- TEST_CLKOUT GPIO0_C1 7 8 GPIO5_B1 UART1_TXD --- 161 GPIO:/sys/class/gpio/gpio161 UART:/dev/ttyS1 5,9 --- --- --- --- GND --- 9 10 GPIO5_B0 UART1_RXD --- 160 GPIO:/sys/class/gpio/gpio160 UART:/dev/ttyS1 5,8 5,12 GPIO:/sys/class/gpio/gpio164 SPI:/dev/spidev0 UART:/dev/ttyS4 164 UART4_CTSN SPI0_CLK GPIO5_B4 11 12 GPIO6_A0 I2S_SCLK --- 184 GPIO:/sys/class/gpio/gpio184 6,0 5,14 GPIO:/sys/class/gpio/gpio166 SPI:/dev/spidev0 UART:/dev/ttyS4 166 UART4_TXD SPI0_TXD GPIO5_B6 13 14 --- GND --- --- --- --- 5,15 GPIO:/sys/class/gpio/gpio167 SPI:/dev/spidev0 UART:/dev/ttyS4 167 UART4_RXD SPI0_RXD GPIO5_B7 15 16 GPIO5_B2 UART1_CTSN --- 162 GPIO:/sys/class/gpio/gpio162 UART:/dev/ttyS1 5,10 --- --- --- --- VCC3.3V_IO --- 17 18 GPIO5_B3 UART1_RTSN --- 163 GPIO:/sys/class/gpio/gpio163 UART:/dev/ttyS1 5,11 8,9 GPIO:/sys/class/gpio/gpio257 SPI:/dev/spidev2 257 --- SPI2_TXD GPIO8_B1 19 20 --- GND --- --- --- --- 8,8 GPIO:/sys/class/gpio/gpio256 SPI:/dev/spidev2 256 --- SPI2_RXD GPIO8_B0 21 22 GPIO5_C3 --- --- 171 GPIO:/sys/class/gpio/gpio171 5,19 8,6 GPIO:/sys/class/gpio/gpio254 SPI:/dev/spidev2 254 --- SPI2_CLK GPIO8_A6 23 24 GPIO8_A7 SPI2_CSN0 --- 255 GPIO:/sys/class/gpio/gpio255 SPI:/dev/spidev2.0 8,7 --- --- --- --- GND --- 25 26 GPIO8_A3 SPI2_CSN1 --- 251 GPIO:/sys/class/gpio/gpio251 SPI:/dev/spidev2.1 8,3 7,17 GPIO:/sys/class/gpio/gpio233 I2C:/dev/i2c-4 233 --- I2C4_SDA GPIO7_C1 27 28 GPIO7_C2 I2C4_SCL --- 234 GPIO:/sys/class/gpio/gpio234 I2C:/dev/i2c-4 7,18 5,13 GPIO:/sys/class/gpio/gpio165 SPI:/dev/spidev0.0 165 UART4_RTSN SPI0_CSN0 GPIO5_B5 29 30 --- GND --- --- --- --- 5,16 GPIO:/sys/class/gpio/gpio168 SPI:/dev/spidev0.1 168 --- SPI0_CSN1 GPIO5_C0 31 32 GPIO7_C7 UART2_TXD PWM 239 GPIO:/sys/class/gpio/gpio239 UART:/dev/ttyS2 PWM:/sys/class/pwm/pwmchip3 7,23 7,22 GPIO:/sys/class/gpio/gpio238 UART:/dev/ttyS2 PWM:/sys/class/pwm/pwmchip2 238 PWM2 UART2_RXD GPIO7_C6 33 34 --- GND --- --- --- --- 6,1 GPIO:/sys/class/gpio/gpio185 185 --- I2S_LRCKRX GPIO6_A1 35 36 I2S_LRCKRX UART3_RXD --- 233 GPIO:/sys/class/gpio/gpio223 UART:/dev/ttyS3 7,7 7,8 GPIO:/sys/class/gpio/gpio224 UART:/dev/ttyS3 224 --- UART3_TXD GPIO7_B0 37 38 GPIO6_A3 I2S_SDI --- 187 GPIO:/sys/class/gpio/gpio187 6,3 --- --- --- --- GND --- 39 40 GPIO6_A4 I2S_SDO0 --- 188 GPIO:/sys/class/gpio/gpio188 6,4
  15. 1 point
    hello @saeed soleimanifar, you can get the console log disabled by modifying the /boot/cmdline.txt: console= save and then reboot
  16. 1 point
  17. 1 point
    hello @sonyan11, i think you're able to modify uvcvideo driver to module mode through menuconfig, but tinker board 2s is not able to recognize the new module because the module driver is not updated to tinker board 2s. to update tinker board 2s' module driver, please execute these two commands in the kernel directory of the source code, make ARCH=arm64 modules make ARCH=arm64 modules_install INSTALL_MOD_PATH={INSTALL_PATH} and then update the \lib\modules\4.4.194\ kernel and \lib\modules\4.4.194\modules (of which from {INSTALL_PATH} ) onto tinker board 2s accordingly
  18. 1 point
    hello @sathish, it is not built in the tinker os, if you'd like to use dhcpcd: sudo apt-get install dhcpcd5 the dhcpcd.con will be locaed in /etc/ alternatively, you can use nmcli con mod to configure the ip network
  19. 1 point
    hello @sushil, is this the library you're using? mattjlewis/diozero: Java Device I/O library that is portable across Single Board Computers and microcontrollers. Tested with Raspberry Pi, Odroid C2, BeagleBone Black, Next Thing CHIP, Asus Tinker Board and Arduinos / Pico. Supports GPIO, I2C, SPI as well as Serial communication. Also known to work with Udoo Quad. (github.com)
  20. 1 point
    hello @lbispo, we've verified with tinker edge t mendel os when using two cameras, both cameras can be recognised. please give it a try.
  21. 1 point
    Hi @tooz I'm facing an issue using the webcam inside our electron.js app. we are trying to build electrojs app and use the camera feed inside of it, but it's rendered as a black screen, and we get these errors in the console. libGL error: unable to load driver: rockchip_dri.so libGL error: driver pointer missing libGL error: failed to load driver: rockchip libGL error: unable to load driver: rockchip_dri.so libGL error: driver pointer missing libGL error: failed to load driver: rockchip do you have any idea about those errors?
  22. 1 point
    to compile boot.img: source build/envsetup.shlunch WW_Tinker_Board_2-userdebug./build.sh -CKA it'll be located in directory: rockdev/Image-WW_Tinker_Board_2/
  23. 1 point
    hello @marco@bigsis.tech, 1. connect tinker edge r to the computer 2. shutdown tinker edge r 3. repower tinker edge r so it can be switched to ums mode 4. use tools such as balena etcher to flash
  24. 1 point
    hello @paul_nicholls, this is a tinker board '1.2' with no emmc (rk3288 based), you can download one of the images and burn it into microsd with balenaetcher android 12: Tinker Board R2.0 /Tinker Board S R2.0 Android 12 V0.0.3 debian 10: Tinker Board S R2.0 Debian 10 V3.0.11
  25. 1 point
    hello @CardeLL, try 're-writing the os using ums from a micro sd card': User-Manual.pdf (asus.com)
  26. 1 point
    nevermind. i solved this portion. posted the guide here for anyone who is interested: https://github.com/wahahawasabi/TinkerBoard2s
  27. 1 point
    Kernel Build Questions in Tinker Edge T I installed Mendel 5 Eagle V3.0.2 on Tinker Edge T. I want to change Boot Logo of Tinker Edge T, and I want to communicate with UART device in Mendel Linux. To change the Boot Logo, Kernel must be compiled. Where can I download the kernel source for Mendel 5 Eagle V3.0.2? And, what do I need to do to communicate with the UART device in mendel linux? Guid documentation says /dev/ttymxc0 and /dev/ttymxc2 should exist, but I see /dev/ttymxc0 and /dev/ttymxc1. If /dev/ttymxc1 is checked, it is said to be incorrect. I need help with the above two. regards.
  28. 1 point
  29. 1 point
    hello @Chridster1, thanks for the update, i'll discuss with team in terms of meta-layer releases; for the build issue, please try prebuilt gcc and see if it works: $ make ARCH=arm64 CROSS_COMPILE=../prebuilts/gcc/linux-x86/aarch64/gcc-linaro-6.3.1-2017.05-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- tinker_board_2_defconfig $ make ARCH=arm64 CROSS_COMPILE=../prebuilts/gcc/linux-x86/aarch64/gcc-linaro-6.3.1-2017.05-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- rk3399-tinker_board_2.img -j8
  30. 1 point
    hello @Junhyuk Oh, please revert these two changes from kernel: a11f35719c4d logo: change linux kernel logo by ADC request. 95e5b2643333 logo: Show linux logo and dump kernel log to display during system booting.
  31. 1 point
    Hi @Excel Tinker board 2 supports 3x USB 3.2 Gen 1 TYPE-A ports and 1x USB3.2 Gen 1 TYPE-C OTG port. The TYPE-A and TYPE-C ports are each in a separate USB 3.2 Gen 1 group. Since the three TYPE-A ports of Tinker Board 2 are implemented by USB HUB. When each TYPE-A port is used individually, each port can support up to 5Gbps; however, when all 3 TYPE-A ports are used simultaneously, they will share 5Gbps of bandwidth. If you have a requirement for two 5Gbps USB ports, it is recommended that you use TYPE-A and TYPE-C to implement your requirement, respectively. Thanks.
  32. 1 point
    hello @hisataro, thanks for the details. at this point, we would suggest to re-flash the device first: User Guide · TinkerBoard/TinkerBoard Wiki (github.com) once the flashing is done, please copy the boot image to the device. the boot.img file (TB2_Android11_v2.0.6_boot_img) is re-uploaded and can be downloaded here: https://www.asuswebstorage.com/navigate/a/#/s/50AF1C5364224C2BA8C8A5802DD779064 adb push boot.img /storage/emulated/0/Download/ then you can start rooting the device using magisk, please follow along the steps:
  33. 1 point
    Hi @Sohrab: Please reference the following wiki for Tinker Board 2 (RK3399) mraa library on Android. https://github.com/TinkerBoard/TinkerBoard/wiki/Developer-Guide#mraa-library-for-android
  34. 1 point
    hello @hisataro, please try the following and see if the device can be found: fastboot devices if the device has been detected, you can try the reboot fastboot command otherwise, we'd suggest to re-flash the device
  35. 1 point
    Hi @CyberT: The config table's naming of asus gpio input and output node are for Tinker Board S. And, the packages are development by third party member(https://github.com/tinycore-hisanori/node-red-contrib-tinkeros-gpio). But, i think it is compatible with Tinker Board 2 about gpio pin number. You can replace the attachment file to /home/linaro/.node-red/node-moduels/red-contrib-tinkeros-gpio/nrgpio.sh file and asus output node would work by add sudo permission for Tinker Board 2. Please help to try and verify it. Thank a lot! nrgpio.sh
  36. 1 point
    I couldn't find a complete solution to the problem but here is one way to install: sudo apt update sudo apt -y upgrade sudo apt install apache2 sudo apt install mariadb-server sudo mysql_secure_installation sudo apt install -y lsb-release ca-certificates apt-transport-https software-properties-common gnupg2 wget -qO - https://packages.sury.org/php/apt.gpg | sudo apt-key add - sudo apt update sudo apt install php8.1 ------------------------------------------ when clogged press ctrl+z ------------------------------------------ sudo reboot sudo dpkg --configure -a sudo apt install php8.1-{bcmath,fpm,xml,mysql,zip,intl,ldap,gd,cli,bz2,curl,mbstring,pgsql,opcache,soap,cgi} sudo apt -y upgrade Apache + Mysql + Php 8.1
  37. 1 point
    I was a bit busy lately, but after some investigation I managed to find the reason some device trees failed to compile. I realized that "make" invokes the part that causes the error like this in a linux VM: (cat ../arch/arm/dts/rk3036-sdk.dts; echo '#include "rk3036-sdk-u-boot.dtsi"') > arch/arm/dts/.rk3036-sdk.dtb.pre.tmp; while in macOS it is invoked like this: (cat ../arch/arm/dts/rk3036-sdk.dts; echo '\#include "rk3036-sdk-u-boot.dtsi"') > arch/arm/dts/.rk3036-sdk.dtb.pre.tmp; It seems to be caused by the hash character having a special meaning in shell. I managed to fix, and here is the patch: diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib index 12d1123a07..9e419a0890 100644 --- a/scripts/Makefile.lib +++ b/scripts/Makefile.lib @@ -6,6 +6,8 @@ asflags-y += $(EXTRA_AFLAGS) ccflags-y += $(EXTRA_CFLAGS) cppflags-y += $(EXTRA_CPPFLAGS) ldflags-y += $(EXTRA_LDFLAGS) + +hash = \# # # flags that take effect in sub directories @@ -308,7 +310,7 @@ quiet_cmd_dtc = DTC $@ # Modified for U-Boot # Bring in any U-Boot-specific include at the end of the file cmd_dtc = mkdir -p $(dir ${dtc-tmp}) ; \ - (cat $<; $(if $(u_boot_dtsi),echo '\#include "$(u_boot_dtsi)"')) > $(pre-tmp); \ + (cat $<; $(if $(u_boot_dtsi),echo '$(hash)include "$(u_boot_dtsi)"')) > $(pre-tmp); \ $(CPP) $(dtc_cpp_flags) -x assembler-with-cpp -o $(dtc-tmp) $(pre-tmp) ; \ $(DTC) -O dtb -o $@ -b 0 \ -i $(dir $<) $(DTC_FLAGS) \ I tested the patched version in my macOS machine and a linux VM and I was able to compile successfully in both (with appropriate KCFLAGS). Is it possible to get this merged to the main repo in GitHub? Should I open a PR?
  38. 1 point
    Hi @Korre Tinker2 Android does not support extended screen, only mirror. Thanks
  39. 1 point
    ok, i updated as a normal debian distribution, by editing the /etc/apt/sources.list file and replacing "stretch" with "buster". now I have to solve some package dependency problems but can't find the repository http://tprd.asus.com:8000 should it be updated or can it be removed from the list because it is obsolete ? Thank's
  40. 1 point
    Hi doggedly: The following red parts pin are for I2S so that you can't control the pins by gpio ways because the hdmi audio card need the pins. Thank a lot! 126 I2S0_SDO1 GPIO3_D6 29 30 GND 125 I2S0_SDO2 GPIO3_D5 31 32 GPIO4_C2 PWM0 146 150 PWM1 GPIO4_C6 33 34 GND 121 I2S0_FS GPIO3_D1 35 36 GPIO2_C2 UART0_CTSN 82 149 SPDIF_TX GPIO4_C5 37 38 GPIO3_D3 I2S0_SDI0 123 GND 39 40 GPIO3_D7 I2S0_SDO0 127
  41. 1 point
    Sorry for the late reply. Even though the TJ of RK3399 is 125oC, we set the protection temperature at 105oC.
  42. 1 point
    hello @doggedly which image are you using? may i know the version?
  43. 1 point
    hello @doggedly, you can use third party tools such as https://magiskmanager.com/ for rooting.
  44. 1 point
    hello @vladest, 8: GPIO2_C1/UART0 = TX 10: GPIO2_C0/UART0 = RX more information about 40 pin header: https://tinker-board.asus.com/doc_er.html#qsg
  45. 1 point
    I successfully got it working For anyone else who is wondering, I got it working on SPI5 CS -> SPI5_CSN0 CLK -> SPI5_CLK DIN->SPI5_TXD
  46. 1 point
    Hi Brian, try this: use "tinker-power-manager" or find it in "tinker-config" this command-line tool. (make sure you exec it via sudo or root)
  47. 1 point
    I've made some progress: I purge ufw and iptables, then install iptables first then change to iptables-legacy. after that install ufw. ufw seems to works only on iptables-legacy. apt purge ufw iptables apt install iptables update-alternatives --set iptables /usr/sbin/iptables-legacy update-alternatives --set ip6tables /usr/sbin/ip6tables-legacy apt install ufw now: root@linaro-alip:~# ufw allow ssh ERROR: initcaps [Errno 2] modprobe: FATAL: Module ip6_tables not found in directory /lib/modules/4.4.194 ip6tables v1.8.2 (legacy): can't initialize ip6tables table `filter': Table does not exist (do you need to insmod?) Perhaps ip6tables or your kernel needs to be upgraded. Maybe ip6tables are missing in kernel? root@linaro-alip:~# sudo modprobe ip6_tables modprobe: FATAL: Module ip6_tables not found in directory /lib/modules/4.4.194 root@linaro-alip:~# ^C root@linaro-alip:~# sudo modprobe ip6tables modprobe: FATAL: Module ip6tables not found in directory /lib/modules/4.4.194
  48. 1 point
    Hi Pirate, For Tinker Board 2, the max loading (all connectors been connected) power is around 30W. So considering the degradation of conversion efficiency of some power supplies, we provided a conventional 19V's 45W for reference. (You can check with our user manual, https://tinker-board.asus.com/doc_tb2.html#user, page. 18.) So, if your would not connect with power-hungry USB devices, 15~20W should meet most of the usage. (without others, board only, max stress around ~10W.) And the website, it is should be the maintenance error, written too large as a reference value, which we will arrange to revision. Is 12V or 19V better? My understanding is 12V leads to more amps, so should I go 12v? --> No, 12~19V all would re convert to board used voltage, so you can just make sure the totally watt. Is it max 45W or 65W because both websites say a different thing. --> Like above, you can reference 45W or depends on real usage needs. Does anyone have a link to a compatible power supply, preferably on Amazon.ca? --> All safety compliant, and 5.5/2.5mm DC plug, 12~19V +-5% adapters should be fine. (You can find follow info from our user manual too, https://tinker-board.asus.com/doc_tb2.html#user, page. 18.) Thanks.
  49. 1 point
    I'm interested in the way to build a custom image as well. Hope the step-by-step tutorial like this will be available.
  50. 1 point
    Introduction RKNN-Toolkit is a software development kit for users to perform model conversion, inference and performance evaluation on PC, RK3399Pro. AI Compute Stick or RK3399Pro Linux development board. https://github.com/rockchip-linux/rknn-toolkit/tree/v1.3.2
  • Create New...