Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 06/08/2020 in all areas

  1. 3 points
    could you guys release 1 for kernel 5.15.x please? or share how we can compile our own kernels?
  2. 2 points
    Hi everybody, Recently, I have been trying to run some bare metal code on my Tinker Board 2. I managed to compile ARM Trusted Firmware - A successfully with these commands: % git clone https://github.com/ARM-software/arm-trusted-firmware.git tf-a % cd tf-a % export CROSS_COMPILE=~/Developer/Toolchains/aarch64-none-elf/bin/aarch64-none-elf- % make PLAT=rk3399 After that, I tried to build U-Boot with these commands (the CROSS_COMPILE variable is set from previous commands): % git clone https://github.com/TinkerBoard2/u-boot.git uboot % cd uboot % export BL31=../tf-a/build/rk3399/release/bl31/bl31.elf % export KBUILD_OUTPUT=build % make tinker2_defconfig % make This, unfortunately failed with this error: DTC arch/arm/dts/rk3036-sdk.dtb Error: arch/arm/dts/.rk3036-sdk.dtb.pre.tmp:77.1-10 syntax error FATAL ERROR: Unable to parse input tree I tried to fix the problem, and I thought removing 'rk3036-sdk.dtb' from 'arch/arm/dts/Makefile' could work since it seemed to be the device tree of another board that I was building for, which happened to be ill formed. That made the problem disappear, but the same thing happened for 'rk3368-lion.dtb', 'rk3368-sheep.dtb' and a couple of other device trees. I removed them all (7 in total) and the build finally succeeded. I then created a GPT disk image, with a single FAT32 partition with my code compiled, in it. The partition started at sector 18405, so there should have been plenty space for U-Boot. I verified with gdisk that my disk image is not corrupt, so that is clearly not the problem. I tried writing U-Boot into the SD card with the instructions in https://github.com/u-boot/u-boot/blob/master/doc/README.rockchip and https://github.com/u-boot/u-boot/blob/master/doc/board/rockchip/rockchip.rst. Packaging with rockchip miniloader did kind of work, but it printed some unusual characters (Chinese or Japanese?) and a lot of diamonds with single question mark in them at the beginning, and I had to set the baud rate to 120000 to view the output properly. Using U-Boot SPL and U-Boot TPL + SPL only printed one diamond with a question mark in it. I also tried the method provided as an answer to this post, but that did not work, probably because it was for eMMC. I used this command to see if it worked: minicom -D /dev/cu.usbserial-1440 -b 115200 -o I connected my serial to USB cable as instructed in this post I am sure my board is not broken as I was able to run the official Debian image without U-Boot printing any weird characters or problems with baud rate. I wonder, if any Tinker Board engineers could share how U-Boot is built when preparing the official image. Any help is appreciated.
  3. 2 points
    I was able to update Asus's debian to latest version by adding deb http://ftp.us.debian.org/debian testing main contrib non-free to /etc/apt/sources.list.d and then run "sudo apt update" "sudo apt upgrade" but... Disappointed with support level, Asus almost no activity, several questions not answered, software outdated etc
  4. 1 point
    hello @saeed soleimanifar, you can get the console log disabled by modifying the /boot/cmdline.txt: console= save and then reboot
  5. 1 point
    hello @Suntech, the easiest way would be using the dd command to clone everything out of the board then use flashtools such as balena etcher to flash the .img to other boards. 1. connect tinker board 2s to an ubuntu machine 2. to check if tinker board 2s has been recognised, use lsblk 3. to clone the eMMC: sudo dd if=/dev/sdb of=(filename).img bs=1G this will take a while, i've waited for around 35 minutes or so 4. once the cloning is finished, copy the .img file and use flashtools such as balenaetcher to flash the os to other boards *if you don't have an ubuntu machine, you can plug a flash drive to tinker board 2s, and save the output file to the flashdrive (please ensure it's got enough space) change #3 to: sudo dd if=/dev/sdb of=of=/dev/<USB device_name> bs=1G **if you're using a windows pc, you can use win32 disk imager: Win32 Disk Imager - Download [Official Site] 1. connect tinker board 2s to the pc 2. whilst tinker board 2s is in ums mode, use win32 disk imager to copy the emmc Using dd to clone eMMC OS.pdf
  6. 1 point
  7. 1 point
    Hi guys. Let me share Android 11 for Tinkerboard / Tinkerboard S 1-st revision (not R2.0) which Asus marked as outdated/legacy. You can find download link below: Download Android 11 ROM Tinkerboard (not R2.0) Bug reporting are welcome. Release is based on official Asus firmware for Tinkerboard S R2.0.
  8. 1 point
    hello @sathish, it is not built in the tinker os, if you'd like to use dhcpcd: sudo apt-get install dhcpcd5 the dhcpcd.con will be locaed in /etc/ alternatively, you can use nmcli con mod to configure the ip network
  9. 1 point
    hello @sathish, perhaps you can use gst-play-1.0, command: gst-play-1.0 FILE|DIRECTORY|URI [FILE2|DIRECTORY2|URI2] https://gstreamer.freedesktop.org/documentation/frequently-asked-questions/using.html?gi-language=c#how-do-i-use-the-gstreamer-command-line-interface
  10. 1 point
    hello @sushil, is this the library you're using? mattjlewis/diozero: Java Device I/O library that is portable across Single Board Computers and microcontrollers. Tested with Raspberry Pi, Odroid C2, BeagleBone Black, Next Thing CHIP, Asus Tinker Board and Arduinos / Pico. Supports GPIO, I2C, SPI as well as Serial communication. Also known to work with Udoo Quad. (github.com)
  11. 1 point
    hello @lbispo, we've verified with tinker edge t mendel os when using two cameras, both cameras can be recognised. please give it a try.
  12. 1 point
    Hi @tooz I'm facing an issue using the webcam inside our electron.js app. we are trying to build electrojs app and use the camera feed inside of it, but it's rendered as a black screen, and we get these errors in the console. libGL error: unable to load driver: rockchip_dri.so libGL error: driver pointer missing libGL error: failed to load driver: rockchip libGL error: unable to load driver: rockchip_dri.so libGL error: driver pointer missing libGL error: failed to load driver: rockchip do you have any idea about those errors?
  13. 1 point
    hello @kaestli, i use asus adp-33aw x, it's a pretty general one, similar to this: https://www.amazon.com/Adapter-Charger-Compatible-Vivobook-X200MA/dp/B07WC4F1J4/ref=sr_1_10?crid=1X289V37LE3ZA&keywords=adp+33aw&qid=1675320094&sprefix=adp+33a%2Caps%2C279&sr=8-10
  14. 1 point
    How can I access GPIO pins on android 10 without root access? I have a 2s tinker board and I want to access serial pins. Thank you in advance
  15. 1 point
    hello @marco@bigsis.tech, there are different ways and tools to copy/ dump the os either from emmc or sdcard. the easiest way i can think of is to use dd command, usually i clone the os to sdcard and use balena etcher to flash other boards; if your two tinker edge r's are conencted to the same pc, you can direct the path to the board that you're going to flash. 1. insert a sdcard, using lsblk to check its path, in my case it's /dev/mmcblk0 2. clone the os sudo dd if=/dev/mmcblk0 of=/dev/sda/emmc.img conv=noerror,sync or sudo dd if=/dev/mmcblk1 of=/dev/mmcblk0 bs=4M here i clone the whole system and it takes around 18 minutes 3. once it's done, you can use the sdcard to flash another tinker edge r under ums mode, using tools such as balena etcher
  16. 1 point
    hello @marco@bigsis.tech, 1. connect tinker edge r to the computer 2. shutdown tinker edge r 3. repower tinker edge r so it can be switched to ums mode 4. use tools such as balena etcher to flash
  17. 1 point
    hello @CardeLL, try 're-writing the os using ums from a micro sd card': User-Manual.pdf (asus.com)
  18. 1 point
    nevermind. i solved this portion. posted the guide here for anyone who is interested: https://github.com/wahahawasabi/TinkerBoard2s
  19. 1 point
    hello @kokim_gt, you will have to port and configure tw9992 driver for mipi-csi. awb_v10.c is the library that rockchip uses for awb processing and we do not have source code, something related to rockchip image processing was changed (in this case, ov5647 driver) hence why the rkisp_3a errors. both tw9992 and adb7282m convert analog video(ntsc/pal) to yuv image through mipi-csi output, such application hasn't been implemented in tinker series, as far as i know
  20. 1 point
    Kernel Build Questions in Tinker Edge T I installed Mendel 5 Eagle V3.0.2 on Tinker Edge T. I want to change Boot Logo of Tinker Edge T, and I want to communicate with UART device in Mendel Linux. To change the Boot Logo, Kernel must be compiled. Where can I download the kernel source for Mendel 5 Eagle V3.0.2? And, what do I need to do to communicate with the UART device in mendel linux? Guid documentation says /dev/ttymxc0 and /dev/ttymxc2 should exist, but I see /dev/ttymxc0 and /dev/ttymxc1. If /dev/ttymxc1 is checked, it is said to be incorrect. I need help with the above two. regards.
  21. 1 point
    Hi Nott: Can you try ?? wget https://github.com/electron/electron/releases/download/v11.2.3/chromedriver-v11.2.3-linux-arm64.zip unzip chromedriver-v11.2.3-linux-arm64.zip ./chromedriver Thanks.
  22. 1 point
    hello @metala, the two parts used here are: MURATA/DLW21SN900HQ2L , CHILISIN/CMHD21T-900M-N
  23. 1 point
  24. 1 point
    hello @Chridster1, thanks for the update, i'll discuss with team in terms of meta-layer releases; for the build issue, please try prebuilt gcc and see if it works: $ make ARCH=arm64 CROSS_COMPILE=../prebuilts/gcc/linux-x86/aarch64/gcc-linaro-6.3.1-2017.05-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- tinker_board_2_defconfig $ make ARCH=arm64 CROSS_COMPILE=../prebuilts/gcc/linux-x86/aarch64/gcc-linaro-6.3.1-2017.05-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- rk3399-tinker_board_2.img -j8
  25. 1 point
    hello @Junhyuk Oh, please revert these two changes from kernel: a11f35719c4d logo: change linux kernel logo by ADC request. 95e5b2643333 logo: Show linux logo and dump kernel log to display during system booting.
  26. 1 point
    hello @hasank, we cannot reproduce the issue, but for most cases external disks without individual power supply consume a lot of power that causes connection problem. we'd suggest to use a seperate power supply for the external disk, otherwise use an usb hub with external power supply.
  27. 1 point
    Unfortunately Asus made Tinker Board, sold it and forgot. What makes Raspberry pi popular is the software support behind it. In this forum, your posts are approved very late and receive no response. Unfortunately, I also bought Tinker Board 2S. I regret. There is no support.
  28. 1 point
    Hi @Excel Tinker board 2 supports 3x USB 3.2 Gen 1 TYPE-A ports and 1x USB3.2 Gen 1 TYPE-C OTG port. The TYPE-A and TYPE-C ports are each in a separate USB 3.2 Gen 1 group. Since the three TYPE-A ports of Tinker Board 2 are implemented by USB HUB. When each TYPE-A port is used individually, each port can support up to 5Gbps; however, when all 3 TYPE-A ports are used simultaneously, they will share 5Gbps of bandwidth. If you have a requirement for two 5Gbps USB ports, it is recommended that you use TYPE-A and TYPE-C to implement your requirement, respectively. Thanks.
  29. 1 point
    Hi @Sohrab: Please reference the following wiki for Tinker Board 2 (RK3399) mraa library on Android. https://github.com/TinkerBoard/TinkerBoard/wiki/Developer-Guide#mraa-library-for-android
  30. 1 point
    Hi @CyberT: The config table's naming of asus gpio input and output node are for Tinker Board S. And, the packages are development by third party member(https://github.com/tinycore-hisanori/node-red-contrib-tinkeros-gpio). But, i think it is compatible with Tinker Board 2 about gpio pin number. You can replace the attachment file to /home/linaro/.node-red/node-moduels/red-contrib-tinkeros-gpio/nrgpio.sh file and asus output node would work by add sudo permission for Tinker Board 2. Please help to try and verify it. Thank a lot! nrgpio.sh
  31. 1 point
    Hi, We are new to Tinker Board coming from Raspberry Pi 4. We need an OS to build upon and to decide which components we want to install. Although the Asus Linux guys seem to have don a great job in building a Linux with all the bells and whistles, but our system must be light weight, as it runs as an IoT device and I can not afford/risk to update any oft the certainly upcoming vulnerabilities in packets which we are not using anyways. As we will run 1000s of these devices, I can not carry around unnecessary packets. So instead of taking the heavy Tinker OS, throwing away everything Asus was working so hard on, I need a Debian base image to add stuff. Raspberry OS has a tiny version which was a perfect start, but it does not run on ATB . So far, I haven't been able to install anything else than Tinker OS. All alternatives I tried simply did not start up (regardless of the maskrom jumper): DietPi Tinker Board DietPi RockPro64 Armbian Debian ARm Tinker OS boots up immediately. Is there a Debian based distro available to start building the required configuration upon? Thanks
  32. 1 point
    I couldn't find a complete solution to the problem but here is one way to install: sudo apt update sudo apt -y upgrade sudo apt install apache2 sudo apt install mariadb-server sudo mysql_secure_installation sudo apt install -y lsb-release ca-certificates apt-transport-https software-properties-common gnupg2 wget -qO - https://packages.sury.org/php/apt.gpg | sudo apt-key add - sudo apt update sudo apt install php8.1 ------------------------------------------ when clogged press ctrl+z ------------------------------------------ sudo reboot sudo dpkg --configure -a sudo apt install php8.1-{bcmath,fpm,xml,mysql,zip,intl,ldap,gd,cli,bz2,curl,mbstring,pgsql,opcache,soap,cgi} sudo apt -y upgrade Apache + Mysql + Php 8.1
  33. 1 point
    $ sudo dd if=/dev/mmcblk1 of=/home/linaro/Desktop/mmcblk1.img bs=X count=Y conv=noerror,sync [NOTE]: X means Block size; Y means Processing number of blocks. X*Y has to a little bit bigger than the resized capacity. The dd procedure needs to reserve some space to process. If the reserve space is not enough, the dd procedure would be failed. For example: For this case, the bs would be 5M and count would be 1000 and the created image size would be 5GB totally. Then the created image could be restored back to the whole storage of the next board by dd/ecther/Win32DiskImager. PS: u can follow way to rezise storage partition before u backup the image https://github.com/TinkerBoard/TinkerBoard/wiki/Developer-Guide#for-tinker-board-2s
  34. 1 point
    Hi @hasank Because of XAMPP's installer not provide Arm platform, is only x64 based. So that is why error. Suggests to install service stand alone to enable web server, e.g. Apache, PHP, etc Thanks.
  35. 1 point
    Samba doesn't want to be installed using other dependencies as an excuse. but i solved his problem. it's ok with one command, like this: sudo apt-get install python-samba samba-common-bin samba-libs samba libwbclient0 libsmbclient
  36. 1 point
    Hi @Korre Tinker2 Android does not support extended screen, only mirror. Thanks
  37. 1 point
    Hi guys, I was wanting to change the android startup logo, there are two steps, the tinker board logo and the animated ANDROID logo, is it possible to change both? I tried following the instructions from the website:https://tinkerboarding.co.uk/wiki/index.php/Boot-logo But nothing happens, I'm doing the adb through the typeC connector, and putting the following commands: 2.2 adb root 2.3 adb remount 2.4 adb push bootanimation.zip /system/media/ 2.5 adb shell 2.6 sync 2.7 reboot 2.8 After rebooted, the logo is on the screen. All commands are performed successfully, but when rebooting the tinkerboard logo still remains, nothing happens. I created my logo in 1920x1080 resolution 24bit color bmp format, and renamed it to logo.bmp and added it to the .zip named bootanimation.zip The question is, do you need a right name for the image? what can i be doing wrong? Thanks
  38. 1 point
    Hi @hikaru I use Tinker2S version 2.0.0-20210413 CONFIG_USB_SERIAL_CH341=y Actually insert CH340 USBtoUART linaro@linaro-alip:~$ ls -al /dev/ttyUSB0 crw-rw---- 1 root dialout 188, 0 Dec ?8 04:04 /dev/ttyUSB0 If you have any questions, Please provide dmesg kernel log information. Thanks
  39. 1 point
    linaro@tinkerboard:~$ linaro@tinkerboard:~$ linaro@tinkerboard:~$ cat /etc/*release PRETTY_NAME="Debian GNU/Linux 9 (stretch)" NAME="Debian GNU/Linux" VERSION_ID="9" VERSION="9 (stretch)" VERSION_CODENAME=stretch ID=debian HOME_URL="https://www.debian.org/" SUPPORT_URL="https://www.debian.org/support" BUG_REPORT_URL="https://bugs.debian.org/" linaro@tinkerboard:~$ linaro@tinkerboard:~$ uname -a Linux tinkerboard 4.4.132+ #1 SMP Wed Aug 21 19:15:55 CST 2019 armv7l GNU/Linux linaro@tinkerboard:~$ linaro@tinkerboard:~$ linaro@tinkerboard:~$ sudo apt-get update Err:1 http://tprd.asus.com:8000 stretch InRelease Could not resolve 'tprd.asus.com' Hit:2 http://repo.linaro.org/ubuntu/linaro-overlay stretch InRelease Hit:3 http://security.debian.org stretch/updates InRelease Ign:4 http://cdn-fastly.deb.debian.org/debian stretch InRelease Hit:5 http://cdn-fastly.deb.debian.org/debian stretch-updates InRelease Hit:6 http://cdn-fastly.deb.debian.org/debian stretch Release Reading package lists... Done W: Failed to fetch http://tprd.asus.com:8000/dists/stretch/InRelease Could not resolve 'tprd.asus.com' W: Some index files failed to download. They have been ignored, or old ones used instead. linaro@tinkerboard:~$ linaro@tinkerboard:~$ linaro@tinkerboard:~$ sudo apt-get upgrade -y Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. linaro@tinkerboard:~$ linaro@tinkerboard:~$ ------------------------------------------------------------------------------------- there is also this error Err: 1 http://tprd.asus.com:8000 stretch InRelease Could not resolve 'tprd.asus.com' has the repository address changed ? thank's
  40. 1 point
    Hi doggedly: The following red parts pin are for I2S so that you can't control the pins by gpio ways because the hdmi audio card need the pins. Thank a lot! 126 I2S0_SDO1 GPIO3_D6 29 30 GND 125 I2S0_SDO2 GPIO3_D5 31 32 GPIO4_C2 PWM0 146 150 PWM1 GPIO4_C6 33 34 GND 121 I2S0_FS GPIO3_D1 35 36 GPIO2_C2 UART0_CTSN 82 149 SPDIF_TX GPIO4_C5 37 38 GPIO3_D3 I2S0_SDI0 123 GND 39 40 GPIO3_D7 I2S0_SDO0 127
  41. 1 point
    Sorry for the late reply. Even though the TJ of RK3399 is 125oC, we set the protection temperature at 105oC.
  42. 1 point
    hello @doggedly which image are you using? may i know the version?
  43. 1 point
    If there's any failure encountered during the OS writing process on Tinker Board S, you can either recover using the UMS from eMMC if eMMC’s U-Boot still workable, or re-writing the OS using UMS from a microSD card if there's a problem booting from eMMC's U-bbot. Below are the procedures: UMS from eMMC eMMC’s U-Boot still workable and had built-in the UMS function. Can use the UMS mode to re-flash The eMMC need have a workable U-Boot. Connect Tinker Board S to PC via Micro-USB. It would booting & create the partitions like a USB drive. (please remove other extend device on board) Just flash as the old way. UMS from SD card eMMC’s U-Boot is broken to booting or not built-in the UMS function (e.g. 3rd party custom image). Can trigger the UMS mode from SD card Flash the Image (with UMS’s U-Boot) to SD card. Install the SD card to Tinker Board S. Plug the Jumper on the Maskrom mode. (force to boot from SD, jump out the eMMC) Connect Tinker Board S to PC via Micro-USB, then there will become as USB mass storage on your computer Then you can flash the eMMC as usual, the old way. (e.g.: win32DiskImager, etcher and so on) After finish the image flash, unplug the USB from PC and then put the jumper at the "no function" mode. Plug in the AC adaptor to boot the device It would boot successfully & create the partitions like a USB drive. (please remove other extend device on board) Without UMS mode Recovery from SD’s image system & without the PC mode (ready on TinkerOS v2.0.4 or above) Plug the Jumper on the Maskrom mode. (force to boot from SD, jump out the eMMC) Flash the Image (any can bootable) to SD card. Plug the SD card to Tinker Board S. Booting the Tinker Board S. It would booting to the RootFS. Then dd or other ways to flash new image file to eMMC(mmcblk1). * Further details could be find on Setup - Tinker Board Wiki (tinkerboarding.co.uk).
  44. 1 point
    hello @vladest, 8: GPIO2_C1/UART0 = TX 10: GPIO2_C0/UART0 = RX more information about 40 pin header: https://tinker-board.asus.com/doc_er.html#qsg
  45. 1 point
    I successfully got it working For anyone else who is wondering, I got it working on SPI5 CS -> SPI5_CSN0 CLK -> SPI5_CLK DIN->SPI5_TXD
  46. 1 point
    Hi Brian, try this: use "tinker-power-manager" or find it in "tinker-config" this command-line tool. (make sure you exec it via sudo or root)
  47. 1 point
    Here is document showing now Pins 3/5 -> I2C bus 6 Pins 27/28 -> I2C bus 7
  48. 1 point
    Hi Pirate, For Tinker Board 2, the max loading (all connectors been connected) power is around 30W. So considering the degradation of conversion efficiency of some power supplies, we provided a conventional 19V's 45W for reference. (You can check with our user manual, https://tinker-board.asus.com/doc_tb2.html#user, page. 18.) So, if your would not connect with power-hungry USB devices, 15~20W should meet most of the usage. (without others, board only, max stress around ~10W.) And the website, it is should be the maintenance error, written too large as a reference value, which we will arrange to revision. Is 12V or 19V better? My understanding is 12V leads to more amps, so should I go 12v? --> No, 12~19V all would re convert to board used voltage, so you can just make sure the totally watt. Is it max 45W or 65W because both websites say a different thing. --> Like above, you can reference 45W or depends on real usage needs. Does anyone have a link to a compatible power supply, preferably on Amazon.ca? --> All safety compliant, and 5.5/2.5mm DC plug, 12~19V +-5% adapters should be fine. (You can find follow info from our user manual too, https://tinker-board.asus.com/doc_tb2.html#user, page. 18.) Thanks.
  49. 1 point
    Hi Zener, Maybe you should connect micro usb directly to power transformers to avoid booting into UMS mode. Apart from this, what is the version of the Tinker Board image? In the uart log of the release version Tinker_Board-Debian-Stretch-V2.1.16-20200813: MMC: dwmmc@ff0c0000: 1, dwmmc@ff0f0000: 0 Test MMC(0)... *** Warning - bad CRC, using default environment There is no information about boot.env and boot.scr, but still can boot into kernel normally. Thanks and best regards, Frank.
  50. 1 point
    Introduction RKNN-Toolkit is a software development kit for users to perform model conversion, inference and performance evaluation on PC, RK3399Pro. AI Compute Stick or RK3399Pro Linux development board. https://github.com/rockchip-linux/rknn-toolkit/tree/v1.3.2
×
×
  • Create New...