Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 06/08/20 in Posts

  1. 3 points
    could you guys release 1 for kernel 5.15.x please? or share how we can compile our own kernels?
  2. 2 points
    Hi guys. Let me share Android 11 for Tinkerboard / Tinkerboard S 1-st revision (not R2.0) which Asus marked as outdated/legacy. You can find download link below: Download Android 11 ROM Tinkerboard (not R2.0) Bug reporting are welcome. Release is based on official Asus firmware for Tinkerboard S R2.0.
  3. 2 points
    Hi everybody, Recently, I have been trying to run some bare metal code on my Tinker Board 2. I managed to compile ARM Trusted Firmware - A successfully with these commands: % git clone https://github.com/ARM-software/arm-trusted-firmware.git tf-a % cd tf-a % export CROSS_COMPILE=~/Developer/Toolchains/aarch64-none-elf/bin/aarch64-none-elf- % make PLAT=rk3399 After that, I tried to build U-Boot with these commands (the CROSS_COMPILE variable is set from previous commands): % git clone https://github.com/TinkerBoard2/u-boot.git uboot % cd uboot % export BL31=../tf-a/build/rk3399/release/bl31/bl31.elf % export KBUILD_OUTPUT=build % make tinker2_defconfig % make This, unfortunately failed with this error: DTC arch/arm/dts/rk3036-sdk.dtb Error: arch/arm/dts/.rk3036-sdk.dtb.pre.tmp:77.1-10 syntax error FATAL ERROR: Unable to parse input tree I tried to fix the problem, and I thought removing 'rk3036-sdk.dtb' from 'arch/arm/dts/Makefile' could work since it seemed to be the device tree of another board that I was building for, which happened to be ill formed. That made the problem disappear, but the same thing happened for 'rk3368-lion.dtb', 'rk3368-sheep.dtb' and a couple of other device trees. I removed them all (7 in total) and the build finally succeeded. I then created a GPT disk image, with a single FAT32 partition with my code compiled, in it. The partition started at sector 18405, so there should have been plenty space for U-Boot. I verified with gdisk that my disk image is not corrupt, so that is clearly not the problem. I tried writing U-Boot into the SD card with the instructions in https://github.com/u-boot/u-boot/blob/master/doc/README.rockchip and https://github.com/u-boot/u-boot/blob/master/doc/board/rockchip/rockchip.rst. Packaging with rockchip miniloader did kind of work, but it printed some unusual characters (Chinese or Japanese?) and a lot of diamonds with single question mark in them at the beginning, and I had to set the baud rate to 120000 to view the output properly. Using U-Boot SPL and U-Boot TPL + SPL only printed one diamond with a question mark in it. I also tried the method provided as an answer to this post, but that did not work, probably because it was for eMMC. I used this command to see if it worked: minicom -D /dev/cu.usbserial-1440 -b 115200 -o I connected my serial to USB cable as instructed in this post I am sure my board is not broken as I was able to run the official Debian image without U-Boot printing any weird characters or problems with baud rate. I wonder, if any Tinker Board engineers could share how U-Boot is built when preparing the official image. Any help is appreciated.
  4. 2 points
    I was able to update Asus's debian to latest version by adding deb http://ftp.us.debian.org/debian testing main contrib non-free to /etc/apt/sources.list.d and then run "sudo apt update" "sudo apt upgrade" but... Disappointed with support level, Asus almost no activity, several questions not answered, software outdated etc
  5. 1 point
    hello @Jovan, it's not possible to read the cmos battery voltage due to hardware design. the input supply voltage range cannot be read externally
  6. 1 point
    Hi guys. Let me share Android 12 for Tinkerboard / Tinkerboard S 1-st revision (not R2.0) which Asus marked as outdated/legacy. You can find download link below: Download Android 12 ROM Tinkerboard (not R2.0) Bug reporting are welcome. Release is based on official Asus firmware for Tinkerboard S R2.0.
  7. 1 point
    Here it is : adb connect [tinker boad ethernet IP] adb root adb remount adb push MindTheGapps-12.1.0-arm-20231025_200802\system\product /system adb push MindTheGapps-12.1.0-arm-20231025_200802\system\system_ext /system adb push MindTheGapps-12.1.0-arm-20231025_200802\system\addon.d /system adb shell pm trim-caches 128G adb reboot
  8. 1 point
    Sorry, here is the working link: Download Android 11 ROM Tinkerboard (not R2.0)
  9. 1 point
    hello @Jovan, was the led (led1) on while using? please check if you're able to use the adb with mask2 cap on while booting?
  10. 1 point
    hello @Jovan, 1. the connection should be type c port (tinker board 3n) to type a port (macbook) 2. both the jumper caps need to be removed 3. no need to adjust mask1 dip switch
  11. 1 point
    hello @Jovan, the cc logic controllers between tinker board 2s and tinker board 3n are different -- for tinker board 3n, if both the ports connected are type c port, the controller will not be able to recognise which port should be in host mode and which port should be in device mode. for tinker board 3n i would recommend to connect type c port from tinker board 3n to type a (macbook)
  12. 1 point
    hello @zain, here are some examples for your reference: https://github.com/rockchip-linux/rknn-toolkit/tree/master/examples/mxnet/fcn_resnet101 you can also check chapter 7.15 Export a segmentation model from 02_Rockchip_User_Guide_RKNN_Toolkit_V1.7.5_EN.pdf
  13. 1 point
    thank you sir, @tooz! mraa works normally. Thank you very much.
  14. 1 point
    hello @lloydhussell, it's a decision for google to make -- my guess is once the feature rolls out there's a chance that aicore will not be exclusively available on pixel pro 8; if the compatibility meets surely it'll be supported on tinker board 3n as well
  15. 1 point
    hello @26.albertsilva@gmail.com, edp-dp converter is not supported on tinker 3n, the edp connectors can only be used for the edp display panels that are on the qvl: https://tinker-board.asus.com/download/Tinker_Board_3N_QVL.pdf to test out dual screen setup, here i use a hdmi tv and an 15" auo g156hab02 edp panel, with tinker 3n debian 11 image v.1.0.7: modify /boot/config.txt, uncomment the overlay line, save /boot/config.txt and reboot tinker 3n: once the overlay comes effective and the edp is recognised, you can change it to either primary or secondary display in the display settings:
  16. 1 point
    hello @sonyan11, what's the image version you're using? if it's not on the list then the function might not have been added -- my bad. i have updated my previous post with versions that support usb vbus control. for debian 10 kernel 4.4, please use v.2.0.20 or later
  17. 1 point
    hello @captain kirk, imx219 is supported on tinker board r2.0, i don't think you need to add an overlay, but if you must, try modify the last line: overlay=CSI0-IMX219 save and then reboot to test and see if the camera works: gst-launch-1.0 v4l2src device=/dev/video0 ! video/x-raw,format=NV12,width=640,height=480 ! videoconvert ! autovideosink reference: Tinker Board (asus.com)
  18. 1 point
    hello @wahaha, we'll upload the codes by the end of this week, i'll leave a comment with the url once it's done. sorry for the inconvenience.
  19. 1 point
    hello @sk109sk, please add it in /boot/cmdline.txt instead sudo vim /boot/cmdline.txt add this line, save and reboot spidev.bufsiz=65536 you can check the value with: cat /sys/module/spidev/parameters/bufsiz
  20. 1 point
  21. 1 point
    hello @sathish, perhaps you can use gst-play-1.0, command: gst-play-1.0 FILE|DIRECTORY|URI [FILE2|DIRECTORY2|URI2] https://gstreamer.freedesktop.org/documentation/frequently-asked-questions/using.html?gi-language=c#how-do-i-use-the-gstreamer-command-line-interface
  22. 1 point
    Hi @tooz I'm facing an issue using the webcam inside our electron.js app. we are trying to build electrojs app and use the camera feed inside of it, but it's rendered as a black screen, and we get these errors in the console. libGL error: unable to load driver: rockchip_dri.so libGL error: driver pointer missing libGL error: failed to load driver: rockchip libGL error: unable to load driver: rockchip_dri.so libGL error: driver pointer missing libGL error: failed to load driver: rockchip do you have any idea about those errors?
  23. 1 point
    How can I access GPIO pins on android 10 without root access? I have a 2s tinker board and I want to access serial pins. Thank you in advance
  24. 1 point
    hello @paul_nicholls, this is a tinker board '1.2' with no emmc (rk3288 based), you can download one of the images and burn it into microsd with balenaetcher android 12: Tinker Board R2.0 /Tinker Board S R2.0 Android 12 V0.0.3 debian 10: Tinker Board S R2.0 Debian 10 V3.0.11
  25. 1 point
    hello @CardeLL, try 're-writing the os using ums from a micro sd card': User-Manual.pdf (asus.com)
  26. 1 point
    /dtoverlay/config.txt does not exist in Android 11 v1.0.0 Tinkerboard S R2.0 release. There are only cmdline.txt file and overlays folder: WW_Tinker_Board:/dtoverlay $ ls -la total 24 drwxrwxrwx 3 root root 16384 2021-12-14 01:16 . drwxr-xr-x 25 root root 4096 2021-12-14 00:43 .. -rwxrwxrwx 1 root root 58 2021-12-14 00:46 cmdline.txt drwxrwxrwx 2 root root 2048 2021-12-14 00:46 overlays WW_Tinker_Board:/dtoverlay $
  27. 1 point
    nevermind. i solved this portion. posted the guide here for anyone who is interested: https://github.com/wahahawasabi/TinkerBoard2s
  28. 1 point
    Kernel Build Questions in Tinker Edge T I installed Mendel 5 Eagle V3.0.2 on Tinker Edge T. I want to change Boot Logo of Tinker Edge T, and I want to communicate with UART device in Mendel Linux. To change the Boot Logo, Kernel must be compiled. Where can I download the kernel source for Mendel 5 Eagle V3.0.2? And, what do I need to do to communicate with the UART device in mendel linux? Guid documentation says /dev/ttymxc0 and /dev/ttymxc2 should exist, but I see /dev/ttymxc0 and /dev/ttymxc1. If /dev/ttymxc1 is checked, it is said to be incorrect. I need help with the above two. regards.
  29. 1 point
    hello @metala, the two parts used here are: MURATA/DLW21SN900HQ2L , CHILISIN/CMHD21T-900M-N
  30. 1 point
    hello @Chridster1, thanks for the update, i'll discuss with team in terms of meta-layer releases; for the build issue, please try prebuilt gcc and see if it works: $ make ARCH=arm64 CROSS_COMPILE=../prebuilts/gcc/linux-x86/aarch64/gcc-linaro-6.3.1-2017.05-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- tinker_board_2_defconfig $ make ARCH=arm64 CROSS_COMPILE=../prebuilts/gcc/linux-x86/aarch64/gcc-linaro-6.3.1-2017.05-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- rk3399-tinker_board_2.img -j8
  31. 1 point
    hello @hasank, we cannot reproduce the issue, but for most cases external disks without individual power supply consume a lot of power that causes connection problem. we'd suggest to use a seperate power supply for the external disk, otherwise use an usb hub with external power supply.
  32. 1 point
    Unfortunately Asus made Tinker Board, sold it and forgot. What makes Raspberry pi popular is the software support behind it. In this forum, your posts are approved very late and receive no response. Unfortunately, I also bought Tinker Board 2S. I regret. There is no support.
  33. 1 point
    Hi @Excel Tinker board 2 supports 3x USB 3.2 Gen 1 TYPE-A ports and 1x USB3.2 Gen 1 TYPE-C OTG port. The TYPE-A and TYPE-C ports are each in a separate USB 3.2 Gen 1 group. Since the three TYPE-A ports of Tinker Board 2 are implemented by USB HUB. When each TYPE-A port is used individually, each port can support up to 5Gbps; however, when all 3 TYPE-A ports are used simultaneously, they will share 5Gbps of bandwidth. If you have a requirement for two 5Gbps USB ports, it is recommended that you use TYPE-A and TYPE-C to implement your requirement, respectively. Thanks.
  34. 1 point
    hello @hisataro, thanks for the details. at this point, we would suggest to re-flash the device first: User Guide · TinkerBoard/TinkerBoard Wiki (github.com) once the flashing is done, please copy the boot image to the device. the boot.img file (TB2_Android11_v2.0.6_boot_img) is re-uploaded and can be downloaded here: https://www.asuswebstorage.com/navigate/a/#/s/50AF1C5364224C2BA8C8A5802DD779064 adb push boot.img /storage/emulated/0/Download/ then you can start rooting the device using magisk, please follow along the steps:
  35. 1 point
    hello @hisataro, please try the following and see if the device can be found: fastboot devices if the device has been detected, you can try the reboot fastboot command otherwise, we'd suggest to re-flash the device
  36. 1 point
    Hi @CyberT: The config table's naming of asus gpio input and output node are for Tinker Board S. And, the packages are development by third party member(https://github.com/tinycore-hisanori/node-red-contrib-tinkeros-gpio). But, i think it is compatible with Tinker Board 2 about gpio pin number. You can replace the attachment file to /home/linaro/.node-red/node-moduels/red-contrib-tinkeros-gpio/nrgpio.sh file and asus output node would work by add sudo permission for Tinker Board 2. Please help to try and verify it. Thank a lot! nrgpio.sh
  37. 1 point
    hello @RichUK, you can root the device using Magisk, here's a brief instruction: -- 1. Prepare boot image -- you can either: a. Get the latest boot image from Tinker Board website: Tinker Board (asus.com) or b. build boot image from source code: Tinker Board 2 - Android · GitHub 2. Copy the boot image to your device adb push boot.img /storage/emulated/0/Download/ 3. Download the latest version of Magisk: Installation | Magisk (topjohnwu.github.io) 4. Install Magisk adb install Magisk.apk 5. Launch Magisk from your device 6. Press the Install button 7. Choose “Select and Patch a File” in method, and select the boot.img file, The Magisk app will patch the boot.img file to [Internal Storage]/Download/magisk_patched_[random_strings].img 8. Pull magisk_patched_[random_strings].img to your PC adb pull /storage/emulated/0/Download/magisk_patched_[random_strings].img 9. Flash boot image patched by magisk in fastboot mode adb reboot-bootloader fastboot flash boot magisk_patched_[random_strings].img fastboot reboot --
  38. 1 point
    Hi, We are new to Tinker Board coming from Raspberry Pi 4. We need an OS to build upon and to decide which components we want to install. Although the Asus Linux guys seem to have don a great job in building a Linux with all the bells and whistles, but our system must be light weight, as it runs as an IoT device and I can not afford/risk to update any oft the certainly upcoming vulnerabilities in packets which we are not using anyways. As we will run 1000s of these devices, I can not carry around unnecessary packets. So instead of taking the heavy Tinker OS, throwing away everything Asus was working so hard on, I need a Debian base image to add stuff. Raspberry OS has a tiny version which was a perfect start, but it does not run on ATB . So far, I haven't been able to install anything else than Tinker OS. All alternatives I tried simply did not start up (regardless of the maskrom jumper): DietPi Tinker Board DietPi RockPro64 Armbian Debian ARm Tinker OS boots up immediately. Is there a Debian based distro available to start building the required configuration upon? Thanks
  39. 1 point
    Hi @hasank Because of XAMPP's installer not provide Arm platform, is only x64 based. So that is why error. Suggests to install service stand alone to enable web server, e.g. Apache, PHP, etc Thanks.
  40. 1 point
    I try to use balena Etcher to install https://github.com/home-assistant/operating-system/releases/download/7.4/haos_tinker-7.4.img.xz in UMS mode. But it failed to boot up. No any screen information or current status show off. Did anyone success to install home assistant?
  41. 1 point
    ok, i updated as a normal debian distribution, by editing the /etc/apt/sources.list file and replacing "stretch" with "buster". now I have to solve some package dependency problems but can't find the repository http://tprd.asus.com:8000 should it be updated or can it be removed from the list because it is obsolete ? Thank's
  42. 1 point
    linaro@tinkerboard:~$ linaro@tinkerboard:~$ linaro@tinkerboard:~$ cat /etc/*release PRETTY_NAME="Debian GNU/Linux 9 (stretch)" NAME="Debian GNU/Linux" VERSION_ID="9" VERSION="9 (stretch)" VERSION_CODENAME=stretch ID=debian HOME_URL="https://www.debian.org/" SUPPORT_URL="https://www.debian.org/support" BUG_REPORT_URL="https://bugs.debian.org/" linaro@tinkerboard:~$ linaro@tinkerboard:~$ uname -a Linux tinkerboard 4.4.132+ #1 SMP Wed Aug 21 19:15:55 CST 2019 armv7l GNU/Linux linaro@tinkerboard:~$ linaro@tinkerboard:~$ linaro@tinkerboard:~$ sudo apt-get update Err:1 http://tprd.asus.com:8000 stretch InRelease Could not resolve 'tprd.asus.com' Hit:2 http://repo.linaro.org/ubuntu/linaro-overlay stretch InRelease Hit:3 http://security.debian.org stretch/updates InRelease Ign:4 http://cdn-fastly.deb.debian.org/debian stretch InRelease Hit:5 http://cdn-fastly.deb.debian.org/debian stretch-updates InRelease Hit:6 http://cdn-fastly.deb.debian.org/debian stretch Release Reading package lists... Done W: Failed to fetch http://tprd.asus.com:8000/dists/stretch/InRelease Could not resolve 'tprd.asus.com' W: Some index files failed to download. They have been ignored, or old ones used instead. linaro@tinkerboard:~$ linaro@tinkerboard:~$ linaro@tinkerboard:~$ sudo apt-get upgrade -y Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. linaro@tinkerboard:~$ linaro@tinkerboard:~$ ------------------------------------------------------------------------------------- there is also this error Err: 1 http://tprd.asus.com:8000 stretch InRelease Could not resolve 'tprd.asus.com' has the repository address changed ? thank's
  43. 1 point
    Hi doggedly: The following red parts pin are for I2S so that you can't control the pins by gpio ways because the hdmi audio card need the pins. Thank a lot! 126 I2S0_SDO1 GPIO3_D6 29 30 GND 125 I2S0_SDO2 GPIO3_D5 31 32 GPIO4_C2 PWM0 146 150 PWM1 GPIO4_C6 33 34 GND 121 I2S0_FS GPIO3_D1 35 36 GPIO2_C2 UART0_CTSN 82 149 SPDIF_TX GPIO4_C5 37 38 GPIO3_D3 I2S0_SDI0 123 GND 39 40 GPIO3_D7 I2S0_SDO0 127
  44. 1 point
    Hello, I invested over a year on this project and spent many frustrating hours getting a tablet based OS to perform like a version made for TV's. This is not a finished product, but I thought some of you may find it useful. I am not a developer and therefore cannot guarantee an issue free experience. I stepped away from the project due to getting stuck in many areas. If anyone with the skills, time and willingness to help wants to help me polish this OS...feel free to send me a PM. Without further delay, I present AvA ROM (Android Video Appliance) for Tinkerboard: Download: AvA ROM RC1 Things to know: Based on Android 7.1.2. Works best with keyboard and mouse. Plugging in wireless remotes causes severe slowdown (solution = Android TV Remote app). Shutdown/sleep doesn't work well. Should run on Tinkerboard S. Not licensed for Netflix or Disney Plus (most other apps and games work). Image is 2.46 GB in size (minimum 4GB SD card). There are workarounds for the above licensing woes, solutions are just a Google search away. I am not sure if the forum moderators will approve this post immediately, but look forward to hearing some of you got to try it out. Best regards, WrekLess.
  45. 1 point
    Could I use this SBC to install Ubuntu 20.04 and ROS Noetic?
  46. 1 point
    Hi Brian, try this: use "tinker-power-manager" or find it in "tinker-config" this command-line tool. (make sure you exec it via sudo or root)
  47. 1 point
    Here is document showing now Pins 3/5 -> I2C bus 6 Pins 27/28 -> I2C bus 7
  48. 1 point
    Hi Pirate, For Tinker Board 2, the max loading (all connectors been connected) power is around 30W. So considering the degradation of conversion efficiency of some power supplies, we provided a conventional 19V's 45W for reference. (You can check with our user manual, https://tinker-board.asus.com/doc_tb2.html#user, page. 18.) So, if your would not connect with power-hungry USB devices, 15~20W should meet most of the usage. (without others, board only, max stress around ~10W.) And the website, it is should be the maintenance error, written too large as a reference value, which we will arrange to revision. Is 12V or 19V better? My understanding is 12V leads to more amps, so should I go 12v? --> No, 12~19V all would re convert to board used voltage, so you can just make sure the totally watt. Is it max 45W or 65W because both websites say a different thing. --> Like above, you can reference 45W or depends on real usage needs. Does anyone have a link to a compatible power supply, preferably on Amazon.ca? --> All safety compliant, and 5.5/2.5mm DC plug, 12~19V +-5% adapters should be fine. (You can find follow info from our user manual too, https://tinker-board.asus.com/doc_tb2.html#user, page. 18.) Thanks.
  49. 1 point
    Hi Zener, Maybe you should connect micro usb directly to power transformers to avoid booting into UMS mode. Apart from this, what is the version of the Tinker Board image? In the uart log of the release version Tinker_Board-Debian-Stretch-V2.1.16-20200813: MMC: dwmmc@ff0c0000: 1, dwmmc@ff0f0000: 0 Test MMC(0)... *** Warning - bad CRC, using default environment There is no information about boot.env and boot.scr, but still can boot into kernel normally. Thanks and best regards, Frank.
  50. 1 point
    Introduction RKNN-Toolkit is a software development kit for users to perform model conversion, inference and performance evaluation on PC, RK3399Pro. AI Compute Stick or RK3399Pro Linux development board. https://github.com/rockchip-linux/rknn-toolkit/tree/v1.3.2
×
×
  • Create New...